Massicot

Recadrez et redimensionnez vos images directement dans l’espace privé de SPIP !

Inspiré par le plugin photospip, ce plugin plus minimaliste permet de recadrer et redimensionner les images dans l’espace privé de SPIP.

Une fois le plugin installé et activé, des liens « recadrer l’image » apparaîtront sur les formulaires de logo et les documents. Ils mènent sur une page avec un slider de zoom permettant de réduire la taille de l’image, et de sélectionner une partie de l’image pour la recadrer.

Capture d'écran du formulaire de recadrage

Les fichiers originaux ne sont pas modifiés, on peut toujours revenir aux dimensions initiales. Les transformations choisies s’appliquent uniquement à l’affichage public des images par les balises #FICHIER et #LOGO_*, et il n’y a pas besoin de changer quoi que ce soit dans les squelettes.

Dernière modification de cette page le 14 février 2019

Discussion

28 discussions

  • 1

    Bonjour, dans l’environnement privée d’un site internet sous Spip 3.1.6, je trouve des messages en tableau en haut à droite en disant qu’il y a des erreurs de template par rapport au Plugin Massicot. Je voudrais savoir comment corriger ces erreurs.

    • Bonjour,

      Je pense que c’est parce que j’ai introduit une incompatibilité avec SPIP < 3.2 sans m’en rendre compte… Du coup la solution doit venir du côté du plugin.

      Est-ce que la version 0.8.6 règle le problème ?

    Répondre à ce message

  • 1

    Tout fonctionne comme si le Massicot permettait de recadrer les logos de mots-clés mais pas de les afficher recadrés avec #LOGO_MOT qui persiste à afficher l’image entière.
    Phénomène connu ?
    merci d’avance pour tout renseignement !

    • Je viens de tester sur un SPIP 3.2.3 et la version 0.8.4 du plugin et je ne vois pas de souci. J’ai fait une simple boucle :

      <BOUCLE_mot(MOTS){id_mot=1}>
        #LOGO_MOT
      </BOUCLE_mot>

      et c’est bien la version recadrée du logo qui est affichée.

      Du coup il me faudrait des infos en plus pour essayer de reproduire le problème :

      • Est-ce que le SPIP et les plugins sont à jour ?
      • Quels autres plugins sont installés 
      • Est-ce que la boucle que je propose ci-dessus fonctionne dans ton cas ?

    Répondre à ce message

  • 5
    William Fourche

    Bonjour,
    Sous spip 3.2.3 ; base mysql verifiée, plugin désactivé sans succces, plugin désinstallé sans succes. Cache vidé multiples fois, cache vidé en FTP, rien n’y fait
    pour tous les articles antérieurs à un nouvel article créé puis supprimé, impossible de recafrer les images des nouveaux articles.
    Le recadrage des images des articles antérieurs sans probleme, le recadrage depuis le menu Edition + médiatheque, sans probleme , Mais
    depuis un nouvel article Massicot propose systematiquement de recadrer le logo quelque soit l’image ou les images disponibles
    Recadrer l’image « Logo
    Le recadrage du logo si présent pas de problème

    une idée ??

    • Bonjour,

      Merci pour le rapport de bug, il y a bien un souci avec ça. Je n’ai pas le temps de chercher une solution là tout de suite, mais je le ferai dans ces prochains jours,

    • William Fourche

      Merci pour la reponse

      je vais chercher de mon coté.

    • Je viens de mettre en ligne un correctif pour ce problème, la nouvelle version devrait être disponible dans d’ici peu.

      Est-ce que la version 0.8.4 corrige bien le souci ?

    • William Fourche

      des que la 0.,8.4 apparait je l’installe et test

    • William Fourché

      mise à jour opérationnelle

      bravo pour la reactivité

      William

    Répondre à ce message

  • 3

    bonjour,
    je viens d’installer SPIP 3.2.2 j’ai massicot 0.8.1 et PHP Version 7.0.33-0+deb9u1
    J’ai un pb lorsque je vais sur une vignette, modifier que je scrolle j’obtiens
    j’ai en dessous d’enregistrer , avant la saisie du mot clé

    Notice : Undefined variable : id_vignette in /var/www/stcleophas/plugins/massicot/massicot/massicot_pipelines.php on line 204

    • c’est une petite erreur. Pas très grave, mais c’est pas normal que ton hébergeur affiche publiquement les erreurs.

      je laisse bystrano corriger l’erreur s’il a le temps

    • Merci mais c’est ma faute.
      les erreurs étaient visible car sur ces 2 sites j’avais oublier de supprimer la vision des erreurs dans mes_options.php
      Ton message m’y a fait penser.

    • Bonjour,

      Je viens de publier un correctif, la version 0.8.4 ne devrait plus avoir ce problème. Merci pour le signalement !

    Répondre à ce message

  • 2

    J’ai pas mal d’erreur sur le log liés à la table documents :

    2018-10-23 13:09:51 ::1 (pid 944) :Pub : !INFO : trouver_table : table inconnue ’’ ’documents’
    2018-10-23 13:09:51 ::1 (pid 944) :Pub:ERREUR : Erreur mysql 1146
    2018-10-23 13:09:51 ::1 (pid 944) :Pub:ERREUR : Erreur mysql 1146
    2018-10-23 13:09:51 ::1 (pid 944) :Pub : !INFO : trouver_table : table inconnue ’’ ’documents’
    2018-10-23 13:11:24 ::1 (pid 945) :Pub:ERREUR : Erreur mysql 1146
    2018-10-23 13:11:26 ::1 (pid 945) :Pub:ERREUR : Erreur mysql 1146
    2018-10-23 13:11:34 ::1 (pid 945) :Pub : !INFO : trouver_table : table inconnue ’’ ’documents’
    2018-10-23 13:12:18 ::1 (pid 945) :Pub:ERREUR : Erreur mysql 1146
    2018-10-23 13:12:18 ::1 (pid 945) :Pub:ERREUR : Erreur mysql 1146
    2018-10-23 13:12:18 ::1 (pid 945) :Pub : !INFO : trouver_table : table inconnue ’’ ’documents’
    2018-10-23 13:12:41 ::1 (pid 945) :Pub:ERREUR : Erreur mysql 1146
    2018-10-23 13:12:42 ::1 (pid 945) :Pub:ERREUR : Erreur mysql 1146
    2018-10-23 13:12:42 ::1 (pid 945) :Pub : !INFO : trouver_table : table inconnue ’’ ’documents’
    2018-10-23 13:12:42 ::1 (pid 945) :Pub:ERREUR : Erreur mysql 1146
    2018-10-23 13:12:43 ::1 (pid 945) :Pub:ERREUR : Erreur mysql 1146

    en modifiant les lignes 68,81,89 et 96 (documents => spip_documents)
    et en commentant la ligne 37 ($table = table_objet($table) ;)
    On arrive à s’en débarrassé mais je n’ai pas fait de test
    Est ce qu’il est possible de regarder cela et éventuellement faire quelque chose ou est ce un souci que je suis seul à avoir ?

    • C’est avec quelle version de SPIP ? Et du plugin ?

      Je viens de tester sur un SPIP 3.2.1 avec le plugin en version 0.8.0, et je n’ai pas ces erreurs. Et d’après programmer SPIP, il semble bien qu’il faut déclarer les traitements autos en utilisant « documents » plutôt que « spip_documents ». Du coup c’est étonnant qu’on puisse corriger l’erreur en faisant l’inverse ! Il y a probablement autre chose qui cloche ailleurs…

    • Il s’agit de la version 3.2.1 de spip et de la version 0.8.0 de massicot

    Répondre à ce message

  • 5

    Bonjour,

    J’ai un problème de notice que je comprends pas

    inserer_attribut(massicoter_logo(
    ((!is_array($l = quete_logo('id_mot', 'ON', $Pile[$SP]['id_mot'],'', 0))) ? '':
     ("<img class=\"spip_logo spip_logos\" alt=\"\" src=\"$l[0]\"" . $l[2] .  ($l[1] ? " onmouseover=\"this.src='$l[1]'\" onmouseout=\"this.src='$l[0]'\"" : "") . ' />')), 'mot', $Pile[1]['id_mot']),'class','spip_logo_left') .
    ' ' .

    Une boucle mots avec #LOGO_MOT

    • Bonjour,

      Pourrais-tu poster le message d’erreur en entier ?

    • Re,

      Notice : Undefined index : id_mot in /***/tmp/cache/skel/html_916d7e8556fbe0e30ec0f9eda995c345.php on line 215

    • Autre notice Undefined index : type in /***/plugins/massicot/massicot_pipelines.php on line 88

    • Cette dernière notice devrait être corrigée dans la version 0.7.11 qui vient de sortir.

      Par contre pour la première, je n’arrive pas à la reproduire… Est-ce que tu pourrais poster le bout de squelette qui provoque l’erreur ?

    • Salut,

      J’ai plus de notice pour le moment.
      Je repasse si cela revient.

      Merci

    Répondre à ce message

  • 7

    Salut,

    J’ai remarqué que le plugin généré beaucoup de notice php :

    exemple dans le code php d’un squelette généré :
    http://spip.pastebin.fr/50152 Ligne 227 ;

    On voit qu’il manque des ’quotes’ autour de « article ». je suis quasi certain que ça vient du plugin massicot car lorsque je le désinstalle je n’ai plus de notice.

    Cordialement

    • Effectivement il manquait des quotes, et ça venait bien du massicot, merci pour l’info ! La version 0.7.10 devrait régler le problème.

    • Benoît Labourdette

      De mon côté, il y a un fonctionnement étonnant depuis peu avec ce plugin : lorsque je demande l’affichage du #LOGO_ARTICLE dans un squelette, plus aucun code HTML ne s’affiche. Si je désactive le plugin, ça remarche. Et si j’enlève #LOGO_ARTICLE du squelette, avec le plugin activé, la page s’affiche. Mystère...

    • Le coup de la page blanche, c’est souvent une fatal error php. Est-ce que l’affichage des erreurs php est activé ? Ça permettrait probablement d’avoir plus d’infos sur ce qui cloche.

      On peut forcer l’affichage des erreurs en ajoutant ces deux lignes dans le fichier mes_options.php :

      error_reporting(E_ALL);
      ini_set ("display_errors", "On");
    • Benoît Labourdette

      Merci pour ta réponse. Voici ce que ça donne :

      Fatal error : Allowed memory size of 134217728 bytes exhausted (tried to allocate 16384 bytes) in /home/blab13ourdet/public_html/plugins-dist/filtres_images/filtres/images_transforme.php on line 391

    • Benoît Labourdette

      Merci pour ta réponse. Voici ce que ça donne :

      Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 16384 bytes) in /home/blab13ourdet/public_html/plugins-dist/filtres_images/filtres/images_transforme.php on line 391
    • Ok avec le message d’erreur c’est plus clair :-)

      On dirait que tu as une image trop grande, le module de traitement d’image arrive à court de mémoire et plante tout. Du coup il faudrait augmenter le paramètre memory_limit dans la configuration de php. Le plus simple est probablement de demander à l’hébergeur de le faire..

      Ou alors remplacer l’image en question par une version plus petite..

    • Benoît Labourdette

      C’est génial ! J’avais en effet 2-3 images un peu lourdes. J’en ai mis des versions plus légères, et ça remarche. Merci beaucoup !!!

    Répondre à ce message

  • 2

    Bonjour,

    J’ai un nouveau « petit » souci avec le plugin Massicot...
    Avec un SPIP 3.1.4 (tous les plugins à jour, PHP 7.0.15, hébergement Perfox1 OVH) et le plugin Massicot en v.0.7.8 > Lorsque je diminue de taille une image (illustration) comprise au sein d’un article (ici apposée dans le champs #TEXTE) et que je la recadre à un format lambda (par exemple 607 x 250), il m’affiche en partie publique (et quelques fois en partie privée aussi), une image au format carré : 607 x 607 ! Et impossible de leur faire retrouver leur proportions initiales sauf à désactiver le plugin Massicot... :/

    Par contre, si je n’effectue pas de recadrage sur une image (ici la 4e sur la copie d’écran), cette dernière est parfaitement affichée en partie privée et bien réduite en partie publique... sic...
    Aurais-tu une idée d’où cela peut provenir ?

    Tu écris dans la présentation que le plugin agit sur les balises #FICHIER et #LOGO_* : dois-je en déduire que ce n’est pas utilisable au sein de l’article, dans le champs #TEXTE appelé avec <img4XX> en partie rédactionnelle et dans le gabarit avec le code [(#TEXTE|image_reduire{375,0})] ??

    Si c’est le cas, il faudrait dans ce cas, que le bouton [recadrer l’image] ne soit pas actif dans la section « Illustrations », ce qui interdirait cette manipulation peut-être non prévue...

    Pour constater le souci en partie publique : https://www.commune-fursac.fr/artic...

    • Bonjour Pascual,

      La version 0.7.9 que je viens de mettre sur la zone devrait corriger ça.

      Il y avait un bout de code où j’avais écrit « largeur » au lieu de « hauteur » ! C’est fou qu’après plus d’une année d’existence en prod sur plein de sites, il reste des bugs pareils…

      Merci pour le signalement en tout cas !

    • Nickel, ça fonctionne (mieux) maintenant :D
      Un très grand merci pour ta réactivité !

    Répondre à ce message

  • 3

    Bonjour,

    Sur www.diocese-avignon.fr dans l’espace d’administration, la dernière mise à jour du plugin fait qu’on ne peut plus massicoter un logo.

    En haut au dessus du slider, il y a : « Taille de l’image recadrée en pixels : NaN x NaN » (pour une URL du type : ecrire/ ?exec=massicoter_image&objet=article&id_objet=10578&redirect=.%2F%3Fexec%3Darticle%26amp%3Bid_article%3D10578

    Répondre à ce message

  • 1

    Bonjour,

    Merci pour ce plugin très pratique pour les rédacteurs/administrateurs !

    Je signale juste que j’ai identifié une incompatibilité avec le plugin logo svg (qui permet d’accepter des images au format SVG pour les logos des objets éditoriaux de SPIP). L’activation de Massicot a pour effet de rendre inopérante les balises #LOGO_xxx (j’ai testé #LOGO_SITE_SPIP et #LOGO_ARTICLE) sur la partie publique quand le l’image est au format svg.

    Répondre à ce message

Ajouter un commentaire

Qui êtes-vous ?

Pour afficher votre trombine avec votre message, enregistrez-la d’abord sur gravatar.com (gratuit et indolore) et n’oubliez pas d’indiquer votre adresse e-mail ici.

Ajoutez votre commentaire ici

Ce champ accepte les raccourcis SPIP {{gras}} {italique} -*liste [texte->url] <quote> <code> et le code HTML <q> <del> <ins>. Pour créer des paragraphes, laissez simplement des lignes vides.

Ajouter un document

Suivre les commentaires : RSS 2.0 | Atom