LIM : alléger l’espace privé

Ce plugin permet de désactiver l’affichage de blocs ou de boutons, présents par défaut dans SPIP mais qui peuvent devenir inutiles dans le cadre de votre projet.

Il allège du coup l’interface d’édition et supprime d’éventuels risques de confusion dans l’ajout de contenu éditorial. [1]


Note à propos de la version 1.1
Cette version prend en compte la gestion de tous les objets éditoriaux pour la fonction de restriction des contenus par rubriques

Note à propos de la version 1.3
Si vous avez activé le téléversement des documents pour les rubriques (voir Configuration -> Contenu du site -> Documents joints) la restriction par rubrique fonctionne aussi pour cet objet.

Note à propos de la version 1.4
Nouvelles possibilités d’alléger l’espace privé. Voir le paragraphe« Divers »

Note à propos de la version 2
Cette version de LIM, (uniquement pour SPIP >= 3.2) permet de supprimer la notion de Portfolio dans la gestion de vos documents. Voir le paragraphe « Divers »

Prérequis, installation et configuration

Prérequis
Votre serveur doit proposer une version de PHP supérieur ou égal à 5.5

Installation
Il s’installe comme tous les plugins.

Accès aux pages de configuration
Aller sur la page Configuration -> Gestion des plugins et cliquer sur l’icône de la ligne ’LIM’.

Désactiver les blocs Forums publics et Pétitions

Vous pouvez désactiver l’affichage de ces blocs de vos pages articles.

Pour les forums
Si vous avez désactivé l’utilisation des forums publics, vous pourrez alors désactiver l’affichage du Bloc "Fonctionnement du forum" dans vos pages articles.
Avertissement : ne tient pas compte des options avancées. À utiliser donc si vous n’avez pas du tout besoin des forums publics.

Pour les pétitions
Désactiver l’affichage du bloc "Fonctionnement de la pétition" dans vos pages articles.

Logos au cas par cas

Si vous avez activé les logos (dans Configuration -> Contenu du site), un formulaire de logo s’activera pour tous les objets éditoriaux.

Vous pouvez ici décider de ne pas afficher ce formulaire pour tel objet en particulier.

Contenus par rubrique

Par défaut SPIP ajoute un bouton ’Écrire un nouvel article’, dans toutes les rubriques.
Il en est de même avec le bouton ’Référencer un nouveau site’ si vous activez l’option "Gérer un annuaire de sites Web".

Plus largement, il est possible pour n’importe quel autre objet éditorial amené a être rangé dans une rubrique de choisir précisément les rubriques dans lesquelles créer ces objets.


Avant la restriction par rubrique {PNG}Je ne veux que des actus dans la rubrique Actualités, que des articles dans le Blog, etc. {PNG}et hop… {PNG}
diaporama ’explication par l’exemple’

Interdire l’édition d’un objet éditorial dans une rubrique aura deux conséquences :

  1. supprimer le bouton ’Écrire un nouvel article/breve/site/etc.’ de cette rubrique,
  2. Interdire de créer un article/brève/site/etc. dans cette rubrique.

Bonus
Si vous décider qu’un objet ne peut être ranger que dans une seule rubrique, alors le formulaire d’édition de cet objet n’affichera plus le sélecteur de rubrique.

Incompatibilité avec certains plugins
Cette dernière fonctionnalité, Contenus par rubrique, n’est pas compatible avec la restriction des articles par rubriques avec les plugins suivants :

Certains me rapportent qu’ils ne trouvent pas cela forcément très gênant. À vous de décider…

Divers : portfolio et formulaire Auteurs

Depuis la version 1.4, vous pouvez aussi :

  • Alléger le formulaire Auteur en désactivant (ou non) les champs suivants :
    • Adresse email
    • Qui est l’auteur
    • Clé PGP
    • le fieldset Lien site

Depuis la version 2.0 (uniquement SPIP >= 3.2), vous pouvez aussi :

  • Alléger l’affichage des documents en désactivant la notion de portfolio

Pour les développeurs de plugins

La fonction Contenus par rubrique prend en compte les nouveaux objets éditoriaux (et donc plus seulement les articles, sites référencés et brèves).
Ceci à conditions de mettre (un peu) le nez dans le code.

Explications
Vous devez déclarer les autorisations ad-hoc pour ces objets dans un fichier d’autorisation :
-  dans le fichier squelettes/mes_autorisations.php (à créer si besoin) ;
-  dans le fichier /monplugin/prefixe_autorisations.php.

La déclaration se fait comme suit

if (!function_exists('autoriser_rubrique_creertype_objetdans') AND test_plugin_actif('lim')) {
	function autoriser_rubrique_creertype_objetdans($faire, $type, $id, $qui, $opt) {
		$quelles_rubriques = lire_config('lim_rubriques/type_objet');
		is_null($quelles_rubriques) ? $lim_rub = true : $lim_rub = !in_array($id,$quelles_rubriques);
 
		return
			$lim_rub
			AND autoriser_rubrique_creertype_objetdans_dist($faire, $type, $id, $qui, $opt);
	}
}

Il vous faudra remplacer dans ce code le mot ’type_objet’ par…le type de l’objet.

Note : le type est différent du préfixe.
Pour un objet ’Patates’ :

  • préfixe = ’patates’
  • type = ’patate’

Notes

[1voir également sur le même sujet le plugin Motus : mots-clés utiles que sur certaines rubriques

Dernière modification de cette page le 14 février 2019

Discussion

12 discussions

  • 4

    Bonjour,

    Le PHP est version 5.3.2-1

    J’ai désactivé tous les plugins avant d’installer LIM (dernière version, pas une mise à jour).
    et re-install de tous les autres plugins.

    Cela fonctionne !

    dd

    • Merci DD pour ces infos.

      J’vais abuser encore un peu...peux-tu me donner la liste des plugins ?

      zéro pression hein :)

    • Tu as le choix...

      Accès Restreint 3.8.13 - stable
      Agenda 3.14.13 - stable
      Agrandir la largeur de page 0.3.0 - test
      API de vérification 1.0.8 - stable
      Autorité 0.10.13 - stable
      Bigfoot 1.0.1 - stable
      Champs Extras 3.7.1 - stable
      Comments 3.3.3 - test
      Couteau KISS 1.2.1 - stable
      Crayons 1.25.0 - stable
      Facteur 3.1.3 - stable
      Formidable 2.9.5 - stable
      Formulaire upload html5 1.4.7 - dev
      Inscription 3 3.5.11 - test
      Liens entre contenus 0.30.1 - test
      Liens explicites 2.3.12 - stable
      LinkCheck 1.2.1 - stable
      Logos Médias 0.1.1 - stable
      MailCrypt 2 2.4.2 - stable
      Manuel de rédaction du site 0.9.7 - stable
      Maparaan 1.0.2 - stable
      Menus 1.5.14 - stable
      Mini Calendrier 2.3.9 - stable
      minibando 1.3.3 - stable
      NoSPAM 1.5.13 - stable
      Notifications 3.5.2 - stable
      oEmbed 1.6.0 - stable
      Pages 1.2.11 - stable
      Porte Plume Partout 1.0.7 - test
      Recommander à un ami 1.0.8 - stable
      Saisies pour formulaires 2.5.26 - stable
      Sauvegarde automatique 1.2.0 - stable
      SEO 2.1.4 - test
      Social tags 1.0.12 - stable
      SPIP Bonux 3.2.1 - stable
      SpiPDF 0.2.13 - stable
      Squelette Maparaan 1.0.0 - stable
      Supersized slideshow 0.6.1 - stable
      Thumbsites 1.1.2 - stable
      Varicelle 0.2.2 - stable
      YAML 1.5.2 - stable
      Zpip-dist v1 1.7.29 - stable

    • Génial. Merci DD.

      Pour info : comme il est précisé dans la doc, le plugin LIM n’est pas compatible avec le plugin Autorité.
      Plus précisément la fonction ’Restriction par rubriques’ à des conflits avec la gestion de l’objet ’Article’.

    • Ah bien voilà, ça m’apprendra à pas lire les infos.

      Je n’avais pas
      « déclarer les autorisations ad-hoc pour ces objets dans un fichier d’autorisation »

      donc je pensais pas c’était incompatible.

      Merci
      dd

    Répondre à ce message

  • 1

    Bonjour,

    Ce plugin fonctionne très bien mais pas pour tous les sites testés.

    Sur au moins 2 sites en 3.0.21 l’activation du plugin fait tout planter (pages blanche privée et publique)
    l’URL indiquée lors du plantage :
    http://www.monsite.com/ecrire/?exec=charger_plugin&action=actionner&arg=&hash=a1773af235224ce33de9f4ae29756&redirect=http%3A%2F%2Fwww.site.com%2Fecrire%2F%3Fexec%3Dadmin_plugin

    En supprimant à la main le répertoire du plugin tout redevient normal (ans LIM donc)

    dd

    • As-tu plus d’indications à me donner ? J’ai testé sur 4 sites en 3.0.21 et je n’arrive pas à rerpoduire le bug.

      Version de LIM ?
      Est-ce lors d’une mise à jour 1.0.7 -> 1.1.3 ?
      version de PHP à tout hasard...

      d’avance merci

    Répondre à ce message

Ajouter un commentaire

Qui êtes-vous ?

Pour afficher votre trombine avec votre message, enregistrez-la d’abord sur gravatar.com (gratuit et indolore) et n’oubliez pas d’indiquer votre adresse e-mail ici.

Ajoutez votre commentaire ici

Ce champ accepte les raccourcis SPIP {{gras}} {italique} -*liste [texte->url] <quote> <code> et le code HTML <q> <del> <ins>. Pour créer des paragraphes, laissez simplement des lignes vides.

Ajouter un document

Suivre les commentaires : RSS 2.0 | Atom