Envoyer l’article aux amiEs

Attention, page complètement obsolète, qui devrait être dépubliée : liens brisés, etc.

Un petit plugin qui permet d’afficher un formulaire d’envoi d’un article à une liste d’amiEs.

Ce plugin permet via une balise #FORMULAIRE_ENVOIAMI d’afficher un formulaire d’envoi de l’article à une liste de 4 adresses e-mails.

Il comprend :
-  Contrôle des champs
-  Captcha pour éviter les serveurs de spams
-  Envoi du titre, du chapo et le lien de l’article

Présentation

Boutons en bas de l'article
En cliquant sur le bouton « L’envoyer aux amiEs », par « magie » ;), un formulaire s’affiche
Formulaire d'envoi d'article
Vous avez un aperçu sur ce site entre autres http://www.villemomble.fr/

Installation

-  Copier le répertoire envoiami dans votre répertoire plugins
-  Installer le plugin, , cf. http://www.spip.net/fr_article3396.html
]]

Utilisation

Placez la balise #FORMULAIRE_ENVOIAMI dans le squelette de votre article

Personnalisation

Pour personnaliser le formulaire, éditer le fichier plugins/(...)/envoiami/formulaires/formulaire_envoiami.html
et le fichier plugins/(...)/envoiami/css/envoiami_style.css

Pour juste modifier les boutons : remplacer les boutons plugins/(...)/envoiami/img/... par les vôtres

Détails du code

-  Utilisation de Phpmailer (http://phpmailer.sourceforge.net/)
-  Utilisation du captcha Crypt (http://www.cryptographp.com)
-  Utilisation de Jquery (inclus dans spip 1.9.2 et +) (http://jquery.com/)
-  Utilisation du plugin Jquery Corners (inclus dans ce plugin) (http://www.malsup.com/jquery/corner/)

Version 1.1

Nouveautés par rapport à la version 1.0

-  Changement du nom du répertoire : envoyerami devient envoiami
-  Ajout de la gestion des langues
-  Correction des bogues d’envoi de e-mail (certaines valeurs du formulaire n’étaient pas prises en compte
-  Mise à jour du captcha Crypt (V 1.4)
-  Possibilité d’envoyer le même article plusieurs fois

Envoyer l’article aux amiEs - V.1.1

Version 1.0

Envoyer l’article aux amiEs - V.1.0

Evolutions possibles

Le pourquoi du nombre de quatre pour les amis vient simplement de l’exigence initiale du premier utilisateur. Avec un peu de temps, l’idée serait d’utiliser le plugin cfg pour paramétrer :
-  le nombre d’amiEs auxquels envoyer l’article (bientôt même une page rubrique etc, et pourquoi pas en HTML ou en texte simple)
-  le changement des boutons

Il existe des plugins équivalents, notamment celui de Fil qui s’appelle « Recommander », parmi les plugins TEST sur Spip-zone

Dernière modification de cette page le 9 février 2019

Discussion

21 discussions

  • Du nouveau :

    1. V1 : ca fonctionne seulement avec le zip modifié de Julien (cf. son mail plus bas du 18 juin 2007 à 10:22), merci à lui !

    2. V1.1 : c’est cette portion de code dans formulaire_envoiami.html qui fait planter le squelette :

            <input name="code_script" value="" type="text"  class="envoiamiCacher"/>
    <div align="center" id="kapcha"><?php dsp_crypt(0,1); ?> </div>

    Répondre à ce message

  • Bonjour,

    Je rencontre 2 pbms avec ce plugin :

    1. avec la V1.0 : bien que rempli correctement, le script me dit que le captcha n’est jamais bon !

    2. avec la V1.1 : le formulaire ne s’intègre pas correctement à la page : les boutons n’apparaissent pas et la page est coupée à ce niveau-là...

    Merci pour toute aide.

    Répondre à ce message

  • 1

    Pour moi, sur SPIP2, ca ne marche pas.... l’icone ne s’afffiche simplement pas...
    Agnes

    Répondre à ce message

  • 2

    J’ai un problème déjà signalé ici. J’ai bien essayé toutes les manips proposées. Rien n’y fait !

    Le captcha ne s’affiche pas. Tout fonctionne sauf que le captcha ne s’affiche pas. C’est super ennuyeux.

    Que faire ? Comment faire ?

    Merci pour votre aide !

    • Je n’ai pas précisé l’adresse du site :
      http://snec.acnantes.free.fr
      C’est un site de test.

      Merci pour votre aide

    • Voici le message d’erreur.
      Il manque pas grand chose je pense ...

      Fatal error : Cannot redeclare dsp_crypt() (previously declared in /mnt/165/sda/f/1/snec.acnantes/plugins/envoiami/class/crypt/cryptographp.fct.php:19) in /mnt/165/sda/f/1/snec.acnantes/plugins/envoiami/class/crypt/cryptographp.fct.php on line 19

    Répondre à ce message

  • Tropicaloo

    Bonjour,
    J’aimerai utiliser ce plugin avec Thickbox.
    Quelqu’un saurait-il comment obtenir le formulaire « L’envoyer aux amiEs » déjà ouvert par défaut à l’ouverture de la page sans avoir à l’ouvrir par un clic sur l’image ?

    Répondre à ce message

  • 7

    Bonjour,
    J’ai essayé ce plugin pour remplacer un ancien script et j’obtiens le message d’erreur suivant sur les pages articles après l’install :

    Fatal error : Cannot redeclare dsp_crypt() (previously declared in /opt/lampp/htdocs/site/plugins/envoiami/class/crypt/cryptographp.fct.php:19) in /opt/lampp/htdocs/site/plugins/envoiami/class/crypt/cryptographp.fct.php on line 24

    à par le fait qu’il y a un petit problème, je n’y comprends que dalle

    dd

    • J’ai exactement le même problème, et je ne sais pas du tout comment faire pour arranger ca... est-ce que tu as trouvé depuis ? car moi je patauge...

    • Mathilde

      même problème également, en local et sous free :

      Fatal error : Cannot redeclare dsp_crypt() (previously declared in f :\easy\www\lbn192\plugins\envoiami\class\crypt\cryptographp.fct.php:19) in f :\easy\www\lbn192\plugins\envoiami\class\crypt\cryptographp.fct.php on line 19

    • Moi de même, je ne sais pas du tout d’où peux bien venir le problème :-(

      Personne n’a une petite idée ? -merci-

      Fatal error : Cannot redeclare dsp_crypt() (previously declared in /home.10.18/foxyloun/www/_site/lvdi/plugins/envoiami/class/crypt/cryptographp.fct.php:19) in /home.10.18/foxyloun/www/_site/lvdi/plugins/envoiami/class/crypt/cryptographp.fct.php on line 19

    • Exactement le même type de problème :

       ?Warning : session_start() [function.session-start] : open(/mnt/115/free.fr/2/2/dzogchenparis/sessions/sess_4c19d597b8791bf2cb964de734219816, O_RDWR) failed : No such file or directory (2) in /mnt/115/free.fr/2/2/dzogchenparis/plugins/envoiami/class/crypt/cryptographp.fct.php on line 14"

      sur mon site http://www.dzogchenpa.net

    • Même problème.... :’(

      Personne n’a de solution ?

    • Shagshag

      Bonjour, pour corriger le

      Fatal error : Cannot redeclare dsp_crypt()

      il faut modifier le fichier pluins/envoiami/envoiami_element.php
      ligne 7

      include $cryptinstall ;

      devient

      include_once $cryptinstall ;

    • Idem sur 1.9.2 d

      redeclare dsp_crypt() (previously declared in /Library/WebServer/Documents/testtest/plugins/envoiami/class/crypt/cryptographp.fct.php:19) in /Library/WebServer/Documents/testtest/plugins/envoiami/class/crypt/cryptographp.fct.php on line 24

    Répondre à ce message

  • 6

    A première vue je le trouve sympa ton plugin néanmoins je me pose quelques questions (qui ne se poseraient probablement pas si le code était un peu plus commenté :-) !) :

    -  comment supprimer proprement les boutons « imprimer » et « haut de la page » ?
    -  comment faire en sorte que le formulaire s’affiche sous le bouton et non au-dessus ?
    -  comment remplacer le bouton « envoyer.png » par un lien texte ?

    • Bonjour,

      J’ai apporté quelques modifications au plugin, j’ai placé un zip de la version modifiée ici, le formulaire et le squelette de la page article

      Le code en action : Présentation de l’association ADRIAS
      (Le squelette est dispo là : http://www.adrias17.org/squelettes/ )

      J’ai réduit le nombre « d’amis » à 2, supprimé l’ajout du message qui ne fonctionnait pas chez moi et viré les boutons imprimer et « haut de page ». Pour placer également une icône un peu plus « belle » ;-) (La fonction imprimer est gérée par le squelette)

    • En fait le squelette du formulaire se retrouve dans :
      envoyerami/formulaires/formulaire_envoiami.html
      Tu enlèves les tags HTML des images et tu les remplace par du texte.

    • Ok ca marche merci !

      Le dernier problème : je n’arrive pas à centrer le cryptogramme sur mon formulaire, comment le forcer ?

    • Mathilde

      Salut,

      le lien que tu indiques vers le zip ne fonctionne plus. Une autre adresse ?

      Merci

    • Oups, j’ai fait un nettoyage de mon site (passage de 1.9.3svn à 1.9.2 svn) et j’ai viré le zip, je viens de le remettre en ligne à l’instant !

    • Bonjour

      J’ai installé le plugin. Le formulaire s’affiche bien mais l’image ne s’affiche pas ?

      Que faire ?

    Répondre à ce message

  • 2è soucis : actuellement, le message reçu par les destinataires et assez illisible sur Hotmail, par I Explorer. Tous les accents sont remplacés par les multiples signes que l’on connait tous..

    Sur Yahoo et là avec Firefox, pas de problème de ce côté là mais l’objet du mail n’y est pas. ???

    Voilà mes observations.

    Répondre à ce message

  • 3

    Bonjour, merci pour ce plugin et les divers commentaires qui s’y rapportent.
    j’ai moi aussi installé la fonction. Tout est OK. Cependant, je voudrais y ajouter l’attribut « alt » pour les non voyant-es. Dans quel fichier puis-je l’ajouter SVP ?

    Merci

    • Le fichier est dans /plugins/envoiami/formulaires/formulaire_envoiami.html

    • Dans ce fichier je ne trouve pas l’image ; Ce qui semble normal car il s’affiche après avoir cliqué sur l’image justement.

      Je trouve à présent la direction de l’image dans le dossier Balise/envoiami.php. Je n’aime pas trop toucher à ces fichiers mais je vais essayer..

      Merci en tout cas.

    • Non, évidemment ce n’est par là (balise/envoiami.php) qu’il faut agir. Bon, je trouverai plus tard.

    Répondre à ce message

  • 1
    DanielM

    Bonjour,

    Le plugin fonctionne bien en local (easyphp) sans envoi bien sur (vu la raison sur un autre post).

    Sur le site distant l’insertion de #FORMULAIRE_ENVOIAMI dans le squelette article.html ... ne provoque plus aucune insertion ni dans #INSERT_HEAD ni à l’endroit voulu dans le body !!!!

    La config 1.9.2. avec autres plugins squelette_egt (c’est là que se trouve article.html qui a la balise dynamique) et antispam.

    La seule différence entre les machines :
    -  spip en racine sous easyphp en local
    -  spip dans dossier /site sous la racine du serveur d’exploit

    Je pense à un pb de chemin : qui pourrait m’aider svp ?

    Pistes :
    -  Antispam lui fait bien ses insertions dans #INSERT_HEAD dans les 2 cas,
    -  enviar_email_1_9 me joue le même tour !!!

    C’est visible (ou plutôt on ne voit rien sous les articles)

    • Même probleme que toi et j’ai aussi le squelette EGT + spip 1.9.2

      pas de soluce à proposer (désolé), c’est juste pour que tu te sentes moins seul...

    Répondre à ce message

Ajouter un commentaire

Qui êtes-vous ?

Pour afficher votre trombine avec votre message, enregistrez-la d’abord sur gravatar.com (gratuit et indolore) et n’oubliez pas d’indiquer votre adresse e-mail ici.

Ajoutez votre commentaire ici

Ce champ accepte les raccourcis SPIP {{gras}} {italique} -*liste [texte->url] <quote> <code> et le code HTML <q> <del> <ins>. Pour créer des paragraphes, laissez simplement des lignes vides.

Ajouter un document

Suivre les commentaires : RSS 2.0 | Atom