Utiliser l'éditeur WYSIWYG HTMLAREA 3.0 sous SPIP - comments > Utiliser l'éditeur WYSIWYG HTMLAREA 3.0 sous SPIP 2007-02-26T06:19:49Z https://files.spip.net/Utiliser-l-editeur-WYSIWYG#comment391420 2007-02-26T06:19:49Z <p>Personnellement, j'utilise le <a href="http://bbcomposer.elitwork.com/" class="spip_out" title="Télécharger l'éditeur WYSIWYG pour Firefox" rel='nofollow external'>BBComposer</a> et <a href="http://bbcomposer.elitwork.com/personnalisation.html" class="spip_out" title="Télécharger Spip Typo" rel='nofollow external'>Spip Typo</a>, des extensions pour Firefox. Ce qui est intéressant c'est que l'on peut choisir d'utiliser le XHTML classique (et rester 100% conforme aux standards) ou choisir d'utiliser Spip Typo et les raccourcis typographiques classiques et/ou étendus.</p> <p>Les bonus de l'intégration dans Firefox :</p> <ul class="spip"><li>glisser/déposer avec upload d'images en local ou encore depuis une galerie chargée dans une barre latérale.</li><li>auto-complétion des urls de liens avec l'historique.</li><li>glisser/déposer des marques pages pour créer des liens vers ses sites favoris.</li><li>compatibilité avec tous les OS (linux, windows, Mac).</li><li>possibilité de créer ses propres extensions sans limitation aucune (usage de XUL/JS ou même de C++).</li></ul> <p>Bref, que du bonheur ! :)</p> > Utiliser l'éditeur WYSIWYG HTMLAREA 3.0 sous SPIP 2005-08-29T19:12:59Z https://files.spip.net/Utiliser-l-editeur-WYSIWYG#comment383154 2005-08-29T19:12:59Z <p>Le développement d'HTMLArea semble interrompu. Une autre équipe, un peu plus ouverte et plus active a pris le relais avec Xinha et quelques Plugins intéressants notamment pour nettoyer le code HTML. Je pense que son intégration dans SPIP peut être intéressante et doit être à peu prés semblable à celle d'HTMLArea.</p> > Utiliser l'éditeur WYSIWYG HTMLAREA 3.0 sous SPIP 2005-08-06T22:27:52Z https://files.spip.net/Utiliser-l-editeur-WYSIWYG#comment382721 2005-08-06T22:27:52Z <p>Je viens de l'installer aussi sur SPIP 1.8.1, et je ne vois pas quel est le problème de <i>perte de mémoire sur les balises ??</i> J'ai fait quelques tests de réouvertures d'articles créés par htmlarea et je n'ai pas décelé de problèmes particuliers</p> <p>Thierry</p> > Utiliser l'éditeur WYSIWYG HTMLAREA 3.0 sous SPIP 1.8.1 !!! 2005-08-06T21:42:12Z https://files.spip.net/Utiliser-l-editeur-WYSIWYG#comment382719 2005-08-06T21:42:12Z <p>Pour Stéphane Wacongne,</p> <p>Bonjour,</p> <p>j'ai commencé à vouloir faire l'installation sur la 1.8.1 avant d'avoir lu tes messages. J'ai d'abord fais un «diff» entre le fichier <i>articles_edit.php3</i> modifié et celui original de SPIP 1.7.2, puis ai essayé d'appliquer manuellement les «diffs» sur la version 1.8.1.</p> <p>J'ai bien vu qu'à la ligne 482 de la version 1.8.1, l'objet TEXTAREA avait maintenant un <i>id</i> '<strong>text_area</strong>' alors qu'il n'en avait pas dans la v1.7.2. Cela pose problème puisque la modif d'Aurélien ajoutait un <i>id</i> '<strong>texte</strong>' à cet objet.</p> <p>Je ne sais pas exactement quel est son utilité, mais je suppose qu'il en a une, que ce soit celui de la 1.8.1 ou celui d'Aurélien. Or je vois dans ton message que tu remplaces tout simplement l'id de la v1.8.1 par celui d'Aurélien. Il me semble que cela devrait causer un problème quelque-part, bien que je ne sache pas encore lequel.</p> <p>Thierry</p> > Problème pour Utiliser l'éditeur WYSIWYG HTMLAREA 3.0 sous SPIP 2005-07-28T18:19:35Z https://files.spip.net/Utiliser-l-editeur-WYSIWYG#comment382551 2005-07-28T18:19:35Z <p>Bonjour à tous,</p> <p>Après avoir lu cette contribution et fait l'installation en suivant scrupulesement les notes, voic le message que j'ai :</p> <p>Fatal error: Cannot redeclare mysel() (previously declared <br class="autobr" /> in /home/.filer2/timbaleprod/www/spip/ecrire/articles_edit.php3:217) <br class="autobr" /> in /home/.filer2/timbaleprod/www/spip/ecrire/inc_presentation.php3 on line 3043</p> <p>Quelqu'un a t il une idée ?</p> <p>J'utilise spip 1.8.1.</p> <p>Merci.</p> > Utiliser l'éditeur WYSIWYG HTMLAREA 3.0 sous SPIP 1.8.1 !!! 2005-07-25T21:54:11Z https://files.spip.net/Utiliser-l-editeur-WYSIWYG#comment382467 2005-07-25T21:54:11Z <p>J'ai fait les modifs et une erreur me dit :</p> <p>Parse error: parse error in c:\program files\easyphp1-8\www\spip\spip-v1-8-1\ecrire\articles_edit.php3 on line 497</p> <p>tu sais d'ou ca peut venir ?</p> > Utiliser l'éditeur WYSIWYG HTMLAREA 3.0 sous SPIP 2005-07-22T09:10:40Z https://files.spip.net/Utiliser-l-editeur-WYSIWYG#comment382397 2005-07-22T09:10:40Z <p>L'éditeur s'installe très facilement dans Spip, mais quelle décéption à l'utilisation : il génère un code pas du tout propre. Et si on souhaite revenir sur un article déjà mis en forme, il semble perdre la mémoire sur les balises déjà insérées et tout est à recommencer. Je ne recommande vraiment pas cet outil dans l'état actuel de son fonctionnement. (Utilisé avec Spip 1.8.1 sous IE, PC)</p> ça ne marche pas sous spip1.8.1 2005-07-20T12:08:59Z https://files.spip.net/Utiliser-l-editeur-WYSIWYG#comment382324 2005-07-20T12:08:59Z <p>Bonjour,</p> <p>j'aimerais bien utiliser cet éditeur sous spip1.8.1 surtout qu'il prend en compte les textarea scindées. J'ai suivi les instructions d'installation mais qd j'édite un article, la page articles_edit.php est toute blanche.</p> <p>Merci pour votre aide.</p> > Utiliser l'éditeur WYSIWYG HTMLAREA 3.0 sous SPIP 1.8.1 !!! 2005-06-09T16:15:03Z https://files.spip.net/Utiliser-l-editeur-WYSIWYG#comment381553 2005-06-09T16:15:03Z <p>dans ton code modifié, tu fais référence à un fichier htmlarea/htmlarea.php3. Ce dernier ne se trouve pas dans le zip téléchagé.<br class="autobr" /> Ou le trouver? Merci</p> > Utiliser l'éditeur WYSIWYG HTMLAREA 3.0 sous SPIP 1.8.1 !!! 2005-06-07T15:22:40Z https://files.spip.net/Utiliser-l-editeur-WYSIWYG#comment381477 2005-06-07T15:22:40Z <p>Je viens de me rendre compt d'un petit problème dans mon adaptation de la contrib d'Aurélien pour SPIP 1.8.1 : <strong>on ne peut plus utiliser les racourcis typographiques de la barre de racourcis</strong>... pas très grave pour utiliser HTMLArea donc, mais gênant pour les gens qui continuent à utiliser nos bons vieux racourcis !</p> <p>La méthode est donc la suivante : <strong>suivez les instructions d'installation pour SPIP 1.8 ci-dessus</strong> et en plus, <strong>recherchez autour le la ligne 486</strong></p> <div class="precode"><pre dir="ltr" style="text-align: left;"><code> echo afficher_barre('formulaire', 'texte'); echo "<TEXTAREA id='texte' NAME='texte' ".afficher_claret()." CLASS='formo' ROWS='$rows' COLS='40' wrap=soft>"; echo $texte; echo "</TEXTAREA>\n";</code></pre></div> <p>et remplacez par</p> <div class="precode"><pre dir="ltr" style="text-align: left;"><code> echo afficher_barre('document.formulaire.texte'); echo "<TEXTAREA id='text_area' NAME='texte' ".$GLOBALS['browser_caret']." CLASS='formo' ROWS='$rows' COLS='40' wrap=soft>"; echo $texte; echo "</TEXTAREA>\n";</code></pre></div> > Utiliser l'éditeur WYSIWYG HTMLAREA 3.0 sous SPIP 2005-05-25T09:32:37Z https://files.spip.net/Utiliser-l-editeur-WYSIWYG#comment381243 2005-05-25T09:32:37Z <p>C'est vraiment génial cet editeur! Quelques points tout de même que j'aimerai voir aborder si cela est possible:<br class="manualbr" />Je n'ai que la police Verdana comment peut on rajouter times new roman?<br class="manualbr" />Les interlignes sont trop importants au lieu d'avoir cela<br class="manualbr" />J'ai cela:</p> <p>Cela.</p> <p>Comment remedier à ce problème?<br class="manualbr" />Et dernier petit point: La fonction Lettrine ne peut donc plus fonctionner, puisque il y a du code au début de texte?<br class="manualbr" />(Spip 1.7.2)<br class="manualbr" />Sinon merci énormement! c'est super!! Bravo!!!!</p> > Utiliser l'éditeur WYSIWYG HTMLAREA 3.0 sous SPIP 1.8.1 !!! 2005-05-23T23:29:42Z https://files.spip.net/Utiliser-l-editeur-WYSIWYG#comment381211 2005-05-23T23:29:42Z <p>Désolé, après vérification, c'était un simple problème de cache ! (je débute sous spip).</p> <p>Ca marche donc avec la dernière version (RC1) et spip 1.8.1. J'ai juste un warning qui doit pouvoir être résolu je poense (_editor_url is not set).</p> <p>J'ai juste été un peu décu par les focntionalités de l'éditeur :</p> <p>- difficultés pour avoir le “focus” dans les popup <br />- pas d'upload d'images ce qui me semble très pénalisant pou les rédacteurs.</p> <p>Bref, j'aimerais faire la comparaison avec fckeditor, mais je ne sais pas si la procédure d'integration à spip 1.8.1 existe.</p> <p>Peux-t-on installer les 2 ?</p> > Utiliser l'éditeur WYSIWYG HTMLAREA 3.0 sous SPIP 1.8.1 !!! 2005-05-23T23:10:15Z https://files.spip.net/Utiliser-l-editeur-WYSIWYG#comment381210 2005-05-23T23:10:15Z <p>Bonjour,</p> <p>Chez moi, après modif (spip 1.8.1), les articles que je saisie ne sont plus ajouté dans la liste des derniers articles ajoutés sur le sommaire !</p> <p>D'ou peut venir le problème ?</p> <p>merci et a+</p> > Utiliser l'éditeur WYSIWYG HTMLAREA 3.0 sous SPIP 1.8.1 !!! 2005-05-20T19:18:49Z https://files.spip.net/Utiliser-l-editeur-WYSIWYG#comment381173 2005-05-20T19:18:49Z <p>Merci Stéphane et Aurelien. j'utilise la derniere version de SPIP (1.8.1) cela fonctionns 10000..000% bien.<br class="autobr" /> merci les gars.<br class="autobr" /> (y a pas de femmes qui developpent sous SPIP :-))</p> > Utiliser l'éditeur WYSIWYG HTMLAREA 3.0 sous SPIP 1.8.1 !!! 2005-05-07T11:57:28Z https://files.spip.net/Utiliser-l-editeur-WYSIWYG#comment380902 2005-05-07T11:57:28Z <p>Pour utiliser cette contrib dans Spip 1.8.1, le seul fichier qui ne va pas est ecrire/articles_edit.php3</p> <p>En fait, il a subit quelques modifs depuis Spip 1.7.2 et donc on se retrouve avec des choses bizarres (une même fonction définie 2 fois !) si on reprend le fichier modifié par Aurélien.</p> <p>Mais, pas de panique, il suffit de suivre faire comme suit : <br />- télécharger l'archive et copier le répertoire htmlarea à la racine du site <br />- d'éditer ecrire/articles_edit.php3 (celui de votre Spip 1.8.1) ; faites une sauvegarde de l'original avant, on sait jamais <br />- dedans, remplacer les lignes 465 à 470 ie</p> <blockquote class="spip"><div class="precode"><pre dir="ltr" style="text-align: left;"><code> $textes_supplement .= "<BR>"; $textes_supplement .= afficher_barre('document.formulaire.texte'.$nombre_textes); $textes_supplement .= "<TEXTAREA NAME='texte$nombre_textes'". " CLASS='formo' ".$GLOBALS['browser_caret']." ROWS='$rows' COLS='40' wrap=soft>" . $texte1 . "</TEXTAREA><P>\n";</code></pre></div> </blockquote> <p>par les lignes suivantes</p> <blockquote class="spip"><div class="precode"><pre dir="ltr" style="text-align: left;"><code> // Modifs Aurélien PIERARD $textes_supplement .= "<p align=\"center\"><input type=\"button\" onClick=\"window.open('../htmlarea/htmlarea.php3?idChamp=texte$nombre_textes','_blank','toolbar=0, location=0, directories=0, status=0, scrollbars=0, resizable=0, copyhistory=0, menuBar=0, width=700, height=500');\" value=\"Utiliser l'&eacute;diteur WYSIWYG (popup)\" class=\"fondo\" style=\"font-size:14px; font-weight:bold;\"/></p>\n"; $textes_supplement .= afficher_barre('formulaire', 'texte'.$nombre_textes); $textes_supplement .= "<TEXTAREA id='texte$nombre_textes' name='texte$nombre_textes'". " CLASS='formo' ".afficher_claret()." ROWS='$rows' COLS='40' wrap=soft>" . $texte1 . "</TEXTAREA><P>\n"; // Fin des Modifs Aurélien PIERARD</code></pre></div></blockquote> <p>- puis remplacer les lignes 482 à 485 ie</p> <blockquote class="spip"><div class="precode"><pre dir="ltr" style="text-align: left;"><code> echo afficher_barre('document.formulaire.texte'); echo "<TEXTAREA id='text_area' NAME='texte' ".$GLOBALS['browser_caret']." CLASS='formo' ROWS='$rows' COLS='40' wrap=soft>"; echo $texte; echo "</TEXTAREA>\n";</code></pre></div></blockquote> <p>par les lignes suivantes</p> <blockquote class="spip"><div class="precode"><pre dir="ltr" style="text-align: left;"><code> // Modifs Aurélien PIERARD echo "<p align=\"center\"><input type=\"button\" onClick=\"window.open('../htmlarea/htmlarea.php3','_blank','toolbar=0, location=0, directories=0, status=0, scrollbars=0, resizable=0, copyhistory=0, menuBar=0, width=700, height=500');\" value=\"Utiliser l'&eacute;diteur WYSIWYG (popup)\" class=\"fondo\" style=\"font-size:14px; font-weight:bold;\"/></p>\n"; echo afficher_barre('formulaire', 'texte'); echo "<TEXTAREA id='texte' NAME='texte' ".afficher_claret()." CLASS='formo' ROWS='$rows' COLS='40' wrap=soft>"; echo $texte; echo "</TEXTAREA>\n"; // Fin modifs Aurélien PIERARD /* // traitement automatique des sauts de ligne : pas mur if ($proposer_autobr AND ($options == "avancees")) { echo '<div class="verdana2">'; echo '<input type="checkbox" class="checkbox" name="post_autobr" id="autobr" value="1" />'; echo '<label for="autobr">'._L("prendre en compte les sauts de ligne simples").'</label></div>'; } */</code></pre></div></blockquote> <p>Merci encore pour ta contrib, Aurélien, elle est vraiment super !</p> > Utiliser l'éditeur WYSIWYG HTMLAREA 3.0 sous SPIP 2005-04-29T09:43:07Z https://files.spip.net/Utiliser-l-editeur-WYSIWYG#comment380761 2005-04-29T09:43:07Z <p>Cet éditeur est vraiment bien. Malheureusement l'éditeur ne fonctionne pas sous la version 1.8.1. de SPIP.(Mac OS X Firefox)</p> <p>Je serais très intéressé au développement d'une nouvelle version.</p> > Utiliser l'éditeur WYSIWYG HTMLAREA 3.0 sous SPIP 2005-04-21T19:09:33Z https://files.spip.net/Utiliser-l-editeur-WYSIWYG#comment380570 2005-04-21T19:09:33Z <p>Est-ce compatible avec SPIP 1.8 ?</p>