Vérifier ses plugins pour le passage à SPIP 3.1

Lister tous les plugins actifs et leur compatibilité avec SPIP 3.1

Ce plugin est un petit outil pour simplifier la vie du webmaster qui souhaite passer son site de SPIP 3.0 à SPIP 3.1. Il permet de vérifier si ces plugins sont compatibles avec SPIP 3.1 (voir désormais Vérifier ses plugins avant un changement de version de SPIP).

Une fois le plugin installé, se rendre dans le menu Maintenance > Vérifier ses plugins ... ou directement à la page :
http://monsite/ecrire/?exec=verifie31

La page liste tous les plugins actifs et leurs bornes de comptabilités.

  • Si un plugin est incompatible, on le signale.
  • Si une version plus récente du plugin est compatible, on le signale et propose la mise à jour.

Une fois le site passé en SPIP 3.1, le plugin est inutile, vous pouvez donc le désactiver et le supprimer.

Avertissement

La vérification de compatibilité des plugins se base sur les informations fournies par les plugins eux-mêmes.
Le plugin ne donne pas de garantie si cette compatibilité est réelle ou non.

Que faire si un plugin n’est pas compatible ?

Si un plugin n’est pas compatible, consulter sa documentation pour savoir si une évolution est envisagée. Éventuellement vous pouvez demander à son auteur de le rendre compatible SPIP 3.1 ou le faire vous-même si vous avez les compétences ...

Évolution

Ce plugin teste la compatibilité uniquement avec SPIP 3.1

Un nouveau plugin est maintenant disponible. Il devient permet de tester la compatibilité avec toutes les versions à venir de SPIP 3.2, SPIP 3.3, ....
Vérifier ses plugins avant un changement de version de SPIP

Dernière modification de cette page le 13 février 2019

Discussion

7 discussions

  • Bonjour,

    Merci pour ce plugin bien pratique pour la migration.

    À titre d’info la recherche des plugins dans l’espace privé donne
    Lister ses plugins pour le passage à SPIP 3.1

    Les noms des plugins ne sont pas répertoriés automatiquement dans la recherche ?

    Autre sujet :
    Après une tentative malheureuse de passage de Spip 3.0.21 à 3.1, j’ai installé 3.0.22.

    Vérifier ses plugins pour le passage à SPIP 3.1 m’indique que tous mes plugins actifs sont compatibles 3.1

    Dans une seconde liste des plugins inactifs, il me donne 3 incompatibilités ou à vérifier. Ce qui est un peu étonnant, c’est qu’il y indique des plugins verrouillés comme Breve, Compagnon, dump, revision, une vingtaine en tout

    Y a-t-il un lien avec mon impossibilité actuelle d’afficher ou de gérer mes plugins ?

    Répondre à ce message

  • Jaseur Boreal

    Bonne et excellente année pour vous et tous vos projets,

    Année 2016 : Année SPIP 3.1

    Au 12 janvier 2016 :
    Liste de quelques plugins qui apparaissent incompatibles SPIP 3.1

    • Balise #POPUP [3.0.0 ;3.0.*] Le plugin actuellement installé est signalé comme incompatible ou à vérifier
    • CFG [3.0.0-beta ;3.0.*] Le plugin actuellement installé est signalé comme incompatible ou à vérifier
    • Choix parmi des couleurs [2.0.0 ;3.0.99] Le plugin actuellement installé est signalé comme incompatible ou à vérifier
    • Formulaire de participation Formidable [3.0.0 ;3.0.*] Le plugin actuellement installé est signalé comme incompatible ou à vérifier
    • FreepapeR 2 [3.0.1 ;3.0.*] Le plugin actuellement installé est signalé comme incompatible ou à vérifier
    • Fusions de formulaires pour Formidable [3.0.0 ;3.0.*] Le plugin actuellement installé est signalé comme incompatible ou à vérifier
    • OpenID [2.0.0 ;3.0.99] Le plugin actuellement installé est signalé comme incompatible ou à vérifier
    • Réponses commentées avec Formidable [3.0.0 ;3.0.*] Le plugin actuellement installé est signalé comme incompatible ou à vérifier
    • Transaction [2.0.0 ;3.0.99] Le plugin actuellement installé est signalé comme incompatible ou à vérifier

    Répondre à ce message

  • 4

    Bonjour,

    Voici les plugins listés incompattibles

    Sur un SPIP en 3.0.21) :

    Accès Restreint [3.0.0 ;3.0.*] (pas de mise à jour dispo sur la page d’admin malgré le commentaire)
    CFG [3.0.0-beta ;3.0.*]
    Piwik [2.0.8 ;3.0.*]
    Varicelle [1.9.1 ;3.0.99]

    Sur un SPIP en 3.0.20) :
    Liens entre contenus [3.0.0 ;3.0.*]
    Logos Médias [3.0.0 ;3.0.*]
    Massicot [3.0.17 ;3.0.*]
    Plan du site dans l’espace privé [3.0.0 ;3.0.*]
    Rechercher/Remplacer 3.0.0 ;3.0.*]
    Titre de logo [3.0.0 ;3.0.*]

    dd

    Répondre à ce message

  • Bonjour, voici quelques plugins incompatibles 3.1

    Répondre à ce message

  • 1

    Bonjour,

    Très bien ce plugin. Il me permet de vérifier la compatibilité de certains de mes plugins mais la version 3.1 de Spip n’est pas en ligne…

    Répondre à ce message

  • 5

    Chouette ce plugin.
    En le testant, il m’indique pour plusieurs plugins « La dernière version du plugin sur la zone est compatible, veuillez mettre votre plugin à jour ».
    Sauf que... je suis déjà à jour.
    En fait, pour beaucoup de plugins le paquet.xml a été modifié pour indiquer la compat 3.1, mais sans augmentation du numéro de version z, ils ne sont pas mis à jour localement.

    Répondre à ce message

  • 1

    Le lien présent en debut de cet article ne fonctionne pas : http://contrib.spip.net/files.spip.org/spip-zone/verifie31.zip

    Il faut corriger par http://contrib.spip.net/spip-zone/verifie31.zip

    merci

    Répondre à ce message

Ajouter un commentaire

Qui êtes-vous ?

Pour afficher votre trombine avec votre message, enregistrez-la d’abord sur gravatar.com (gratuit et indolore) et n’oubliez pas d’indiquer votre adresse e-mail ici.

Ajoutez votre commentaire ici

Ce champ accepte les raccourcis SPIP {{gras}} {italique} -*liste [texte->url] <quote> <code> et le code HTML <q> <del> <ins>. Pour créer des paragraphes, laissez simplement des lignes vides.

Ajouter un document

Suivre les commentaires : RSS 2.0 | Atom