Squelette Multi-Saisons

Un squelette qui change de couleurs suivant les saisons, un graphisme tout en rondeurs et de très nombreuses options.

Alfons Mucha, grand peintre, en aurait rêvé. Multi-saisons est un squelette SPIP qui change de couleurs au fil des saisons. Fonctionnel sur SPIP V2, Il intègre de très nombreuses fonctions et affichages :

En standard

-  Annuaire de membre avec pages de contact ;
-  Espace sécurisé, restreint à certains membres ;
-  Kiosque à site web syndiqué rss et annuaire de lien
-  Splickrbox pour afficher votre dernier album photo ;
-  Newsletter SPIP-liste (plugin) avec affichage des formulaires ;
-  Pages de recherches (avec fonctions du plugins recherche étendue) et de 404 pour les articles ou forums supprimés ou restreints.
-  Plus une multitude de petits trucs : formulaire de pétition, de connexion, d’abonnement ... etc.
-  Thickbox ou Nyroceros pour afficher vos photos en diaporama (plugin Thickbox ou Nyroceros) ;

Options

-  option « Multi-saisons » pour que le site change de couleurs (logos + css) au fil des saisons ;
-  Glossaire interne pour les mots complexes (optionnel) ;
-  Annuaire de lien + formulaire de soumission + affichage de fil de syndication via un kiosque avec navigation par date ou site (optionnel) ;
-  Lecteur multimédia- pour vos vidéos et musiques avec le plugin Lecteur Multimedia (optionnel) ;
-  Forum multi-discussions avec avatars, modération à coup de Crayons (optionnel) page de suivi des forums
-  etc...

L’installation, la configuration.

L’installation, la configuration des plugins et des mots clés sont très largement expliqués dans ce site de démonstration et de documentation. Des [forums sont à dispositions pour toutes les questions relatives à ce squelette.

Portfolio

Dernière modification de cette page le 9 février 2019

Discussion

69 discussions

  • 6

    Bonjour,

    j’essaye de personnaliser le plugin « Présentation d’humains »... je suis preque au résultat que je souhaite... La page s’affiche correctement mais en dessous vient se greffer la page d’accueil du Site... Si je ne suis pas clair voyez plutôt en cliquant ICI...

    Dans le code je n’arrive pas à voir ce qui cloche... En même temps je ne suis pas un expert... Donc je sollicite l’aide des pros...

    merci pour vos réponses...

    • On peut voir le code source de la page ?
      As tu touché au code de rubrique.html ?

      j ai lu en diagonale la doc du plugin
      il semble fonctionner avec des includes sur des rubriques / articles dédiés (rubrique-N.html et article-N.html).
      je regardera ptet au niveau de la configuration du plugin au moment ou tu associes une rubrique.

    • Hello,
      Ce n’est pas une page d’accueil mais la page 404. Il doit manquer un petit quelque chose à ton squelette pour que la 404 se greffe dessous.

    • Bonjour,

      Alors pour te répondre je n’est pas touché au code de rubrique html mais je l’ai copier comme base pour l’adapter au fichier inc-rubrique_humains.html du plugin « humain ». Fichier html que j’ai placé dans le Squelette Multi-Saisons... Comment dois je faire pour que tu puisses voir le code source de la page...

      Merci pour ton aide...

    • c’est bien la page 404 qui s’affiche... Mais ce petit quelque chose dont tu parles semble bien difficile à trouver pour mes connaissances... Aurais tu une piste à me donner... Merci de ton aide !!

    • apparemment t’as resolu ton prob.

      je vois plus la 404...

      ou etait le bug ?

    • Ba tout simplement il me manquait la « boucle principale rubrique » en début de page...

      Merci encore pour votre squelette et surtout la rapidité avec laquelle vous essayez de répondre à nos question...

    Répondre à ce message

  • 2

    un grand bravo pour ce magnifique squelette, je ne maitrise pas les boucles et spip, je suis en local sous spip 1.9.2b.
    je désire créer une boucle à l’intérieur d’une boucle existante pour l’algo suivant, car j’ai qques articles en langue arabe :

    .....

    .....

    si mot clé arabe

    alors définir une classe ( changement de direction , right to left)

    afficher le titre + article

    sinon afficher le titre + article courant

    ....

    ....

    mko

    Merci de votre aide

    • Multisaisons n’est pas encore multilangue. Néanmoins un fichier langue a été ajouté sur la zone. Il y a beaucoup de textes à traduire. Beaucoup de squelettes à modifier aussi. Si tu souhaite ajouter de l’arabe ponctuellement, tu peux peut-être essayer de créer un modèle spip. (voir les modèles dans la doc SPIP)

    • Oui, c’est ponctuel, je vais essayer d’intégrer du html au début de l’article pour changer surtout le cadrage du texte à droite ( le texte en arabe s’affiche correctement, mais cadrer à gauche, l’arabe s’écrit de droite vers la gauche), pour les modèles spip ça à l’air compliqué pour moi, mais je vais voir ce que je pourrais faire.

      Merci pour ton aide . MKO

    Répondre à ce message

  • 12
    Nico4peace

    Bonjour,

    est il possible de voir ce que donne une rubrique avec le mot clef forum car sur mon site rien ne change...

    d’avance merci

    • As-tu essayé le plugin « squelette par mot clé ? »

    • Mikado

      Moi aussi quand j’utilise le mot clef forum sur une rubrique spécifique rien ne se passe... Comment faire ? A quoi sert configuration le plugin « squelette par mot clé ?

      Merci Mika

    • J’ai activé le plugin squelette par mot clef puis créé une règle fond : forum groupe : squelette type : rubrique —> il me dit 0 squelette(s) et biensur la rubrique en forum ne s’affiche pas normalement ??

      Je ne comprend pas comment on configure ce plugin....

    • C’est ok j’ai compris pour la config du squelette par mot clés.... désoler... :-(

      Néanmoins, je me pose une nouvelle question :

      -  Les rubriques avec les mots clés « menu_rub » ou « barre_menu » doivent ce classer par chiffre (genre 10. blabla) normalement car ds le code on retrouve bien« par num titre » or sur mon site c’est pas le cas ??

      -  encore une petite, La sélection photos qui se trouve sur la page sommaire.html s’affiche en petit ?? J’ai essayé de réinstaller le plugin mais rien n’y fait.

      -  désoler mais encore une autre, comme je souhaite que les visiteurs s’inscrivent pour pouvoir gérer différentes zone du site sans qu’ils aient accès en rédaction. J’ai configuré spip comme suit « Inscription automatique de nouveaux rédacteurs—> Ne pas accepter les inscriptions » et « Visiteurs—>Accepter l’inscription de visiteurs du site public » or je ne trouve pas comment ils accèdent au formulaire d’inscription ?

      Merci d’avance de votre aide

    • Pour ce qui est des petites photos, j’ai testé en multi couleurs et en monochrome. Cela fonctionne. A moins d’une modif du plugin, je ne vois pas trop ce que ça peut être. Vérifie que tu ai bien l’image PNG du carré au bord rond dans ton répertoire squelettes. Regarde aussi si GD2 est bien actif dans spip.

    • Oui j’ai 2 PNG un nommé carre-80 et un carre-112 et j’ai activé GD2 car au par avant j’étais en convert. Les images sont tjrs petite !?

    • Salut.

      Steph, m’a dit que ce n’etait pas ça... mais je suis tetu.. :-p

      Pourrais tu faire un essai en enlevant de l article, les éléments du plugin multimedia ?
      Puis vide le cache, et retourne voir...

    • Merci à toi Mattheoh mais j’ai affecté le mot clé à un autre article sans plugin multimédia mais rien n’y fait...

      Si non concernant, l’ordre des onglets tu as une idée ?

      merci ...

    • heu tu as bien desassocier le mot clé de l’autre article ?
      verifie bien que tu n’as pas deux articles avec le mot clé , ça pourrait mettre le bazar.

      Pour les num titre, c’est étrange.
      je l ai fait pour le menu (« menu_rub ») et ça fonctionne bien.
      tu as bien la disposition « 10. titre » (ne pas oublier l’espace...) ?

      si ça marche pas, je regarderai ce WE.

      A plus

    • Maintenant que tu as activé GD2, cette taille d’image devrait être affichée. Fais une mise à jour du fichier sommaire.html, vide tout tes caches spip et navigateurs. Normalement ça devrait tourner.

    • Tu as bien desassocier le mot clé de l’autre article ? verifie bien que tu n’as pas deux articles avec le mot clé , ça pourrait mettre le bazar.

      Oui

      Pour les num titre, c’est étrange. je l ai fait pour le menu (« menu_rub ») et ça fonctionne bien. tu as bien la disposition « 10. titre » (ne pas oublier l’espace...) ?

      Pour les articles avec le mot clé barre_menu c’est revenu (pourquoi ??), pour les rubriques avec le mot clé menu_rub. Dans le menu de droite elles restent ds le désordre or au centre elles respectent la classification en 10. xxx

      Si j’ai un peu de temps je vais jeter un oeil !

    • Salut Art,

      J’ai fait ce que tu dis mais toujours rien ? Zarbi...§§ ??

    Répondre à ce message

  • 3

    Bonjour, Ce squelettes est vraiment superbe, c’est exactement le style graphique que je cherchais.

    mais je n’arrive pas a le faire fonctionner.

    j’ai installé spip 1.9.2 et multisaisons.zip du 31 mai

    téléchargé les derniers versions des plugins requis

    j’ai activé tout les plugins et configuré « acces restreint » et « squelette par mot cles ».

    j’obtiens cette erreur

    Champ ’tout_voir’ inconnu

    quelqu’un peut m’aider ?

    • Pour ne plus avoir l’erreur :

      Champ ’tout_voir’ inconnu

      1. Activer le plugin accés restreint

      2. créer une zone d’accés restreint : configuration / acces restreint / créer une nouvelle zone

      3. editer la nouvelle zone, puis valider
      (Remarque, si vous ne voulez pas avoir de rubrique en acces restreint, vous avez simplement a n’en cocher aucune... la zone restreint sera créee mais n’affectera aucune rubrique.)

      4. vider le cache, et retourner voir que l’erreur a bien disparu

      5. Faites tourner la soluce, pq y a du monde qui butte là dessus ;-)

    • merci mattheoh

      il fallait faire encore une petite chose :
      -  se déconnecter du login administrateur

    • Merci beaucoup. J’ai effectivement eu des soucis avec le cache, en local, car depuis mon autre ordi, je viens de voir pour la première fois TOUT QUI MARCHE :-)

    Répondre à ce message

  • 2

    Salut,

    j’avance à grand pas dans la mise en place de mon Site... Pas facile de tout comprendre mais en fouillant et grace à votre aide c’est nickel... merci encore pour votre aide et ce conviviale squelette...

    j’ai réussi à comprendre le fonctionnement de la mise en place d’un forum... Mais... Une question : sur cette PAGE, quand je clique sur le lien « s’inscrire » j’arrive sur cette page... j’aimerai simplement ouvrir la popup qui permette de s’inscrire... Est ce un bug ? Dois-je faire une manip ?

    Merci pour votre aide...
    Mikado

    • Tu dois accepter les inscriptions sur ton site. Sinon les gens ne peuvent s’inscrire. (réponse de Normand... mais bon) Va dans configuration puis interactivité. Heu de tête hein... ce n’est peut-être pas là.

    • merci pour ta réponse afficace, rapide et un peu normande qui m’a permis de régler ce petit souci que j’avais...

      Mikado

    Répondre à ce message

  • 6

    Bonjour,

    Séduit par le squelette, je suis en train de le tester à l’adresse suivante.

    Sur une brêve à laquelle j’ai affecté le mot clé « blogue », cette breve apparait deux fois sur la page d’accueil ??

    De plus, comment faire pour que le squellette affiche les dernières brêves sur le sommaire ? J’ai cru avoir trouvé trace d’une boucle daans le code de la page mais rien ne s’affiche... une subtilité sans doute.

    bon courage pour la suite, merci encore et vivement que l’agenda soit disponible...

    • Bien vu, c’est corrigé. J’ajoute un commit sur la zone. Merci de l’avoir signalé.

    • Bravo - et merci - pour la rapidité de correction.

    • Nico4peace

      Bonjour,

      J’ai télécharger et charger ce-jour (29/05) votre squelette (exellent...) et la brève ayant le mot clef « blogue » s’affiche avec des retours à la ligne de 5cm (environ)

      Je ne sais régler le souci....

      Merci d’avance

    • La modif date pourtant du 25. Voyez sur la zone.

    • Le soucis de doublo de la brêve a bien été corrigé, mais sous firefox en tout cas, le code généré provoque bien des espaces incroyables entre les paragraphes.

      Voir toutjours ici www.khodbreaker.com/sitetest/

    • Supprime le saut de ligne. Le javascript ne le tolère pas ici.

    Répondre à ce message

  • 6

    Bonjour et merci pour ce magnifique squelette !

    Je n’ai pas bien compris comment utiliser les mots clefs... Pourriez-vous m’expliquer un exemple ?

    Merci pour vos réponses

    Mikado

    • Je te donne 2 exemples :

      menu_rub (groupe affichage) :
      Lorsque ce mot clé est associé à des rubriques, cela permet de les afficher dans la page sommaire et dans le menu depliant. (Si tu as des rubriques que tu ne desires pas faire apparaitre, ne leur associe pas ce mot clé)

      images_une (groupe affichage) :
      crée un article et joins lui 8 images (joindre un document). associe lui le mot clé images_une. Tes images apparaitront dans le sommaire dans une splickrbox

      certains mots clés sont plus ou moins utilies, cela dépend essentiellement des besoins de chacun....

      on va essayer tout de même de detailler un peu les explications sur les mots clé pour une meilleure compréhension.

    • Merci pour ces explications, mais peux-tu nous dire où doit-on définir et donc rentrer ces mots clés ? Dans le titre de la rubrique par exemple ?
      Merci pour vos réponses.

      Chris.

    • Autant pour moi, je viens de trouver :-)
      Pour ceux que çà intéresse il faut aller dans Edition —> Mots clés tout simplement.

      Merci encore pour ce sublime squelette.

    • Dans ton interface privé :
      va dans édition / mots clés.
      Puis, tu crées les groupes de mots clés (par exemple affichage), puis les mots clés dedans.
      Enfin tu les associes aux rubriques / articles que tu souhaites.

      Attention lorsque tu crée un groupe de mot clé, en bas il y a noté :
      Les mots-clés de ce groupe peuvent être associés :
      il faut cocher les cases
      -  aux articles
      -  aux rubriques
      -  aux bréves

      afin que tu puisses leur associer les mots clés du groupe.

      Si c’est pas clair , fais une recherche dans spip.net

    • Bonjour,

      déjà bravo pour le squelette, vraiment top !

      mais je n’arrive pas à me servir de menu_rub pour afficher mes rubriques. J’ai pas du comprendre quelque chose mais je ne sais pas quoi... mais les rubriques ne s’affichent pas.

      J’ai bien créé le groupe de mots clés : affichage, puis le mot clé : menu_rub. Là ça ne fonctionnait pas, j’ai voulu associer donc menu_rub à ma rubrique, mais je ne peux pas associer de mot-clé aux rubriques, seulement aux articles (au moment de la rédaction je veux dire). Je suis donc allée dans configuration => configurer squelettes mots => puis j’ai entré ça :
      règle 1 Fond : menu_rub Groupe : affichage Type : rubrique puis ça marche pas non plus.

      Je sais plus quoi faire, merci si quelqu’un peut me filer un petit coup de main ça serait sympa avant que je continue à faire n’importe quoi et à tout détraquer :-) !!!

    • Bonjour
      Déjà le mot clé menu_rub n’a rien a voir avec le plugin squelette par mot clé donc oublie cette partie là.

      Ton problème vient du fait que tu ne peux pas associer un mot clé à une rubrique.

      Pour y parvenir va dans édition / mots clés
      puis pour le groupe affichage, clique sur « modifier ce groupe de mots »

      en bas tu as une option : « Les mots-clés de ce groupe peuvent être associés : »
      tu coches « aux rubriques » puis tu valides.

      Voilà tu n as plus qu’a associer le mot clé menu_rub aux rubriques que tu désires voir apparaitre.

    Répondre à ce message

  • 1
    Renaud

    Bonjour,

    un grand bravo pour ce magnifique squelette plein d’inventivité, vraiment très séduisant !

    juste un souci, peut-être lié à spip : je coche sur les cases des plugins et après validation, ensemble ou séparément, toutes les cases se décochent, et j’ai alors un site tout déconfiguré truffé de bugs...

    incompatibilité entre plugins ?

    est-ce que qqn a une idée ?... Merci

    • si mes souvenirs sont bons j ai eu des soucis de cet ordre avec les plugins agenda, widgetcal et minical...
      si tu les utilises, pourrais tu les desintaller et voir si tu as toujours le problème.
      on en saura un peu plus alors.

    Répondre à ce message

  • 2

    Bonjour, j’ai un souci avec le formulaire qui permet à un visiteur de proposer un lien... J’ai fais la manipulation et cela fonctionne, mais je n’ai que le titre du formulaire qui s’affiche...

    Voici la page en question : Clique ici

    Merci pour votre aide...

    Mikado

    • Du coté de la configuration de spip coté interactivité, il faut que les internautes puissent proposer un site.

    • Ah ba oui... Merci pout ta réponse !!!

      Mikado

    Répondre à ce message

Ajouter un commentaire

Qui êtes-vous ?
  • [Se connecter]

Pour afficher votre trombine avec votre message, enregistrez-la d’abord sur gravatar.com (gratuit et indolore) et n’oubliez pas d’indiquer votre adresse e-mail ici.

Ajoutez votre commentaire ici

Ce champ accepte les raccourcis SPIP {{gras}} {italique} -*liste [texte->url] <quote> <code> et le code HTML <q> <del> <ins>. Pour créer des paragraphes, laissez simplement des lignes vides.

Ajouter un document

Suivre les commentaires : RSS 2.0 | Atom