Carnet Wiki

Liste de vérification pour la configuration d’un serveur hébergeant SPIP 3.0

Version 3 — June 2015 Teddy Payet

Configuration requise

Source : Configuration requise

  • Serveur Apache ou compatible (versions supérieures à la 1.2x)
    • Pas d’impératif ou de préférences pour le système d’exploitation ?
  • PHP 5.1.0 minimum
  • MySQL 5 ET SQLite3
    • SQLite3 nécessaire pour les sauvegardes et restaurations de la base via l’espace privé
  • NetPBM, Imagick/convert, GD1, GD2 (requis) (plus Freetype pour les filtres |image_typo).
    • Imagick et GD2 nécessaires

Autres configuration nécessaires :


Pour les performances

Source : voir notamment Optimiser les performances de SPIP

Si on utilise Mémoization :

  • installation de Xcache
  • par defaut le cache size est 0 ce qui le met en mode ’disable’ : à modifier
    • quelle valeur attribuer ? 16Mo ?

À tester avec http://www.webpagetest.org/