Initializr

Ce thème reprend la page de démo http://www.initializr.com/try en l’adaptant à la sauce ZPIP pour SPIP3

Thème très simple (en développement car il dépend de 2 plugins non stables) est en deux colonnes qui s’adaptent à la taille de l’écran, cela sert de base de travail pour faire du responsive design et en comprendre rapidement le fonctionnement en html5.

Pour en savoir plus, merci de consulter la page http://www.html5-css3.fr/html5/initializr-generateur-template-html5-boilerplate

Le thème s’installe comme n’importe quel thème ZPIP . Il nécessite les plugins Zcore et Z5 que vous pouvez trouver zippés ou sous SVN.

-  Le plugin Z5 (zpip_html5 en dev branches/V2) pour SPIP3 http://files.spip.org/spip-zone/zpip_html5_spip3.zip
-  Le plugin Z-core (en dev) pour SPIP3 http://files.spip.org/spip-zone/z-core.zip

Copies d’écran

Ecran de moins de 480px


Ecran au dessus de 480px

Et puisque vous utilisez le HTML5 de SPIP3, pensez à activer l’option « Permettre le HTML5 » dans la configuration avancée de votre site. Ceci essentiellement pour avoir les bons attributs HTML5 dans les divers formulaires. (login, contact, etc)
Par exemple [(#HTML5) required='required' autofocus='autofocus']

Dernière modification de cette page le 13 février 2019

Discussion

4 discussions

  • rien depuis 2012 ! ça avait l’air pourtant prometteur ??

    Répondre à ce message

  • 2
    goudron kabyle

    Est-ce qu’on peut trouver une version squelette de InitializR, personnellement installer ZPip et un autre plugin ça fait beaucoup.

    • Non ça n’existe pas. Mais, faut essayer, après tu comprendras pourquoi c’est ainsi ! Quand c’est plus simple à distinguer, c’est plus simple à comprendre et à modifier !

    • goudron kabyle

      Merci @touti

    Répondre à ce message

  • 2

    Merci à toi pour la mise à jour. Tout s’installe bien maintenant.
    La lecture de la page du plugin Z5 : http://contrib.spip.net/Zpip-dist-en-HTML5
    me fait poser des questions sur la possibilité d’utiliser ce plugin en prod...

    Un avis à ce sujet ?

    • Hé bien, après enquête personnelle, la notification « obsolète » sur le plugin Z5 a été faite pour la branche/V1 en février 2012.
      Puis, le plugin Z5 a été retravaillé et mis à jour en juin 2012, j’ai posé aujourd’hui 26 aout 2012 un sabot avec la branche/V2.
      On ne devrait plus toucher à cette version V2 lors des développements mais au dossier trunk pour les modifs et mises à jour futures !

      A toi de voir avec ces infos, attends peut-être la rentrée car les choses devraient surement bouger du côté de z-core qui est aussi en dev !
      ++
      touti

    • Merci pour cette info, je vais faire dans le style « il est urgent d’attendre »…

    Répondre à ce message

  • 1

    Bonjour,

    « Le thème s’installe comme n’importe quel thème ZPIP . Il nécessite les plugins Zcore et Z5 qui s’installent automatiquement avec et dépendent de SPIP3. »

    Pour info :

    Problème d’installation sur un SPIP SPIP 3.0.4 [19781] :

    Le dépot de plugins standard est installé : SPIP-Zone - Plugins

    Mais il ne contient pas le plugin Z5 et donc l’installation ne se fait pas.

    Il faudrait mettre Z5 dans le dépot SPIP-Zone, ou indiquer où se trouve Z5…

    Merci d’avance !

    • Ok, j’ai modifié le thème car effectivement les 2 plugins qu’il nécessite ne sont pas stables .
      Merci de la remarque.

    Répondre à ce message

Ajouter un commentaire

Qui êtes-vous ?

Pour afficher votre trombine avec votre message, enregistrez-la d’abord sur gravatar.com (gratuit et indolore) et n’oubliez pas d’indiquer votre adresse e-mail ici.

Ajoutez votre commentaire ici

Ce champ accepte les raccourcis SPIP {{gras}} {italique} -*liste [texte->url] <quote> <code> et le code HTML <q> <del> <ins>. Pour créer des paragraphes, laissez simplement des lignes vides.

Ajouter un document

Suivre les commentaires : RSS 2.0 | Atom