Essayez SPIP 2.1-RC

All contributions published for previous SPIP versions

La version Release Candidate de SPIP est sortie de la forge.

La version Release Candidate de SPIP est sortie de la forge.

Essayez-là et commencez à l’utiliser pour nous aider à régler les derniers petits détails qui nous auraient échappés !

Installation manuelle

Une fois le fichier zip ci-joint téléchargé sur votre ordinateur, vous devrez le décompresser, puis installer l’ensemble, par FTP, sur votre site.

Installation automatique

Récupérez le fichier spip_loader.php (ci-joint) et recopiez-le dans le répertoire où vous voulez installer SPIP (à la racine de votre site Web, par exemple).

Ensuite appelez ce fichier depuis votre navigateur Web
spip_loader.php?chemin=spip/dev/SPIP-branche-2.1.zip
et attendez que le chargement se termine.

Si la procédure échoue, vous devrez effectuer l’installation manuelle à partir du paquet ci-dessus.

updated on 27 July 2015

Discussion

29 discussions

  • 3

    Installée et testée avec wampserver 2.0. Tout semble fonctionner correctement si ce n’est une erreure au moment de vider le cache et sur certaines actions au niveau des plugins :
    “Warning: strlen() expects parameter 1 to be string, array given in C:\wamp\www\dmf\ecrire\inc\utils.php on line 589”

    • Quels plugins utilise-tu ? Ce warning dénonce un appel incorrect de la fonction _chemin()

    • Les plugins utilisés pour ce test sont : “Autorité”, “cfg”, “couteau_suisse” et “spip-bonux”.

    • J’ai fait les mêmes tests (mêmes bases de donnée) avec easyphp et en ligne sur les serveurs du village et je n’ai plus de message d’erreur...Je pense donc que le soucis vient avec l’utilisation de wampserver.
      Par contre l’installation directe de la 2.1 ne fonctionne pas sur mes installations, seule une mise à jour depuis une 2.0.10 fonctionne.
      En installation directe j’obtiens une erreur:
      htaccess inopérant

      Avertissement: la configuration de votre serveur HTTP ne tient pas compte des fichiers .htaccess. Pour pouvoir assurer une bonne sécurité, il faut que vous modifiez cette configuration sur ce point, ou bien que les constantes _DIR_TMP & _DIR_CONNECT (définissables dans le fichier mes_options.php) aient comme valeur des répertoires en dehors de C:/Program Files/EasyPHP5.2.10/www.

      Après cela il m’est impossible de me connecter à l’espace privé et j’obtiens une erreur 404 sur le site public.

    Reply to this message

  • 3
    Charles

    J’ai donc fait de nouveaux tests :

    A partir d’une base vierge, que ce soit sous WampServer 2.0i [11/07/09] (php 5.3.0) ou EasyPHP-5.3.2, le passage à la phase 4 de l’initialisation fut laborieux. Dans les deux système j’ai maintenant cette erreur :

    “Warning: substr() expects parameter 1 to be string, array given in C:\Program Files\EasyPHP-5.3.2\www\100327_audio_2-1-rc\ecrire\public\cacher.php on line 234”

    Quel est le niveau requis de php pour la 2.1 ?
    Avez-vous une idée d’où peut provenir cette erreur ?

    Reply to this message

  • Très stable pour une rc1. A part quelque problème de compatibilité de plugins (guestbook...) le reste fonctionne comme avant. Aucun changement vu sur le site public: les ancien squelettes fonctionnent sans problème.

    http://www.sagc-montagne-escalade.org

    Reply to this message

  • 2
    Charles

    Bonjour à vous,
    Le test (en manuel) sur Wampserver de la 2.1.0-RC [15517] s’est correctement déroulé.
    Par contre un certain nombre de plugins ne fonctionnent pas en php 5.3 voire 5.3.1(exemple PageRank et Lecteur Flash pour MP3 -celui qui n’est pas en auto-). Tout rentre dans l’ordre en php 5.2.11
    Dans tous les cas de test, les “mises à jour automatiques du Couteau Suisse” ne fonctionnent plus.
    Étonnant, bienque la date système soit au 22 mars, un article post daté au 24 mars a été mis en ligne.
    Merci pour ce boulot.
    A+
    Ch

    • Dans tous les cas de test, les “mises à jour automatiques du Couteau Suisse” ne fonctionnent plus.

      Je viens de faire l’essai, tout semble pourtant fonctionner...

      Merci pour ta réponse Pat, je refais des tests demain et te tiens informé. Ch

    • Charles

      J’ai effectué de nouveaux tests. Désolé pour le bruit, seule la nouvelle version de Wampserver semble en cause (ou son paramétrage !) : les fichiers compressés ne s’ouvrent pas. Je ne vois pas ou est le problème, en tout cas ce ne sont ni SPIP ni les plugins qui sont en cause. A+ Ch

    Reply to this message

  • Bonjour
    Bravo pour votre travail.
    Je l’ai installé en manuel sur un site utilisé pour tester les mises à jour: SPIP 2.04 et Ahuntsic (version 1er décembre 2009).

    J’ai oublié de vider le cache avant.

    A la mise en route, erreurs d’exécution de squelettes, puis cela s’est tassé.

    J’ai installé Accès Restreint pour le tester, les erreurs de squelettes sont revenues.
    Je n’ai pas pu vider le cache (erreur).
    J’ai désactivé Accès Restreint et Ahuntsic, le cache est depuis indiqué vide et erreur d’exécution lorsque je le vide. Ahuntsic est toujours visible bien que désactivé.

    Erreur de squelette
    Numéro message squelette boucle Ligne
    1 Filtre #URL_ARTICLE non défini squelettes/inc/inc-sommaire-edito.html _articles_edito 24
    2 Filtre #URL_ARTICLE non défini squelettes/inc/inc-sommaire-edito.html _articles_edito2 64
    3 Filtre #URL_RUBRIQUE non défini squelettes/inc/inc-sommaire-edito.html _rubriques_edito 12
    4 Filtre #URL_ARTICLE non défini squelettes/inc/inc-sommaire-articles.html _article_langue 11

    Erreur lorsque je demande à vider le cache (indiqué comme vide) :

    Fatal error: unlink(../tmp/cache//chargeur/acces_restreint_3_0/action/.ok) [function.unlink]: No such file or directory in /mnt/102/sdb/a/8/regis.lardennois/articles/ecrire/inc/flock.php on line 276

    En bref, il y a encore quelques problèmes.

    J’ai cependant pu jouer un peu avec et je suis intéressé par l’utilisation de cette version sur mon site normal (un peu plus tard!).

    Cordialement.
    Régis

    Reply to this message

  • 3

    Je confirme que sur un site de test (chez free, peut-être pas très performant), la rc fonctionne , divers plugins installés aussi, mais pas les mises à jour auto du Couteau Suisse.

    • Free désactive peut-être les accès distants ?

    • Non, pat, je ne crois pas parce que cette fonction du Couteau Suisse fonctionne sur un autre site spip en 2.010 (version du Couteau 36374).

    • Pas de pb pour moi sur les MàJ couteau suisse, sur la 2.1ß

    Reply to this message

  • Bonjour,

    tout fonctionne bien chez moi, sauf trois plugins :
    -  notations
    -  notifications
    -  actijour

    je les ai désactivés pour l’instant

    Reply to this message

  • 3
    gilles_tagada

    Je viens d’installer cette version RC. Dans la gestion des plugins, je ne trouve pas le bouton pour activer un nouveau plugin?
    Et serait-il possible de savoir quelles évolutions ont été apportées?

    • gilles_tagada

      J’ai effacé tous les plugins puis les ai ensuite réinstallé : cela fonctionne. Peut-être un problème lorsque les plugins ont été activés dans une version précédente?

    • Le bouton “enregistrer” de modification apparait si on coche ou décoche une checkbox dans la liste une fois la page totalement chargée. Ça m’a induit en erreur, et j’ai pensé avoir un problème alors que pas du tout. Peut être la même chose de ton coté ?

    • gilles_tagada

      Dans mon cas, le bouton justement n’apparaissait pas lorsqu’on cochait une case. Après avoir effacé tous les plugins, tout est rentré dans l’ordre.

    Reply to this message

  • klaus++

    SPIP 2.1.0-rc [14698]

    -  ecrire/?exec=config_fonctions&image_process=gd2
    l’affichage de la taille des image que SPIP peut digérer a disparu. Dommage, c’estait joli ;-)

    -  sur un site déjà installé la mise à jour par spip_loader ne marche pas. cf. captures d’écran. La mise à jour par FTP marche très bien.
    http://www.spip.de/IMG/jpg/001-start.jpg
    http://www.spip.de/IMG/jpg/002-erre...
    http://www.spip.de/IMG/jpg/003-upda...
    http://www.spip.de/IMG/jpg/004-upda...

    SPIP 2.1.0-rc SVN [15044]
    -  Pour effectuer la mise à jour de la bdd il faut faire la vérification par FTP même si on est auteur1 / webmestre

    -  Echec de l’installation du plugin Sélection d’articles

    -  Erreur du plugin mediathèque après mise à jour 2.0->2.1: 1 Fehler in Layoutvorlage
    1 SQL-Tabelle « DOCUMENTS_LIENS » unbekannt ../plugins/auto/mediatheque/prive/inc-galerie.html _liens 114
    Tentative de mise à jour échoue: Warning: touch() [function.touch]: Utime failed: Operation not permitted in /srv/www/web21/web/ecrire/inc/pclzip.php on line 3856
    Réinstallation de la médiathèque après l’avoir effacé sur le serveur -> OK

    -  après mise à jour 2.0->2.1: nécessité d’actualiser la liste des plugins disponibles pour l’installation automatique

    -  après mise à jour 2.0->2.1: erreur du plugin lecteur multimédia flash

    Autrement c’est super! Merci à tous les contributeurs et contributeuses ;-)

    Reply to this message

  • 3

    Pour être certaine qu’il se s’agissait pas en effet d’erreur de codage de ma part, je suis repassée à spip 2.0.10 (version stable), et toutes les erreurs, ou tous les codes non interprétés avec la version 2.1 de spip se sont remis à fonctionner...
    Pour être plus précise:
    -  les plugins étaient à jour. D’ailleurs, pour faire mon test, je n’avais activé que skeleditor... directement pensé pour la version 2.1 et cfg... même pas spip-bonux!
    -  au cas où, mon FTP de test est un 60gp de chez ovh
    -  pour les tables externes, voici un exemple de boucle non reconnue (j’avais un message d’erreur disant que les tables WP_POSTS et WP_COMMENTS étaient inconnues...)

    <BOUCLE_youp(WP_POSTS){post_title=#TITRE}>
    <BOUCLE_idyoup(WP_COMMENTS){comment_post_id=#ID}></BOUCLE_idyoup> <img src="/IMG/commentaire.png"> #SET{wp,#TOTAL_BOUCLE}<//B_idyoup>
    </BOUCLE_youp><//BOUCLE_youp>
             <BOUCLE_decompte(FORUMS) {id_article}{plat} />[(#TOTAL_BOUCLE|plus{#GET{wp}})] <//B_decompte> réaction(s)

    -  pour le filtre typographique, je parlais d’un code comme [(#TITRE|image_typopolice=comm.ttf,taille=17,couleur=71A9B0)]

    ma police comm.ttf est bien présente dans le sous dossier “polices” de squelettes... mais spip se borne à afficher mon titre dans la police dustissimo...

    -  pour l’erreur sur #URL_DOCUMENT, je ne sais pas du tout... mais avec la version précédente de spip, la stable, je n’ai aucun souci, sachant que comme je suis en train de refaire un site, je suis partie du squelette de la dist, pour le modifier progressivement, je ne pense donc pas avoir intégré de code barbare....

    • Tu as une étrange façon d’écrire tes boucles dont je me demande si elle ne peut pas expliquer tes mésaventures... C’est la présence de la balise <//B_nomdetaboucle> sans qu’il y ait de balise </B_nomdetaboucle> qui la précède... Je me demande comment est interprété le code dans ces conditions...
      Je ne sais pas si ça a réellement un rapport, mais, bon, on peut toujours commencer par remetttre les choses au carré

    • je suis étonné que tes tables soient reconnus sous SPIP 2.1. Si elle sont réellement externe à SPIP, il faut que la syntaxe soit du type <BOUCLE_youp(xxx:WP_POSTS)>http://programmer.spip.org/Declarer-une-autre-base

      pour le titre typo, l’extension “filtres images” a-t-elle bien été installé automatiquement ?

    • merci à vous deux pour ces pistes... je vais en effet corriger ce code (je l’avais généré il y a au moins un an, je n’ai pas pensé à y regarder depuis, étant donné que ça fonctionnait!), et ensuite retenter avec spip 2.1 pour voir ce qu’il me dit!

    Reply to this message

Comment on this article

Who are you?
  • [Log in]

To show your avatar with your message, register it first on gravatar.com (free et painless) and don’t forget to indicate your Email addresse here.

Enter your comment here

This form accepts SPIP shortcuts {{bold}} {italic} -*list [text->url] <quote> <code> and HTML code <q> <del> <ins>. To create paragraphs, just leave empty lines.

Add a document

Follow the comments: RSS 2.0 | Atom