Escal-V3 et Escal-V4

Un jeu de squelettes proposant un affichage en 2 ou 3 colonnes avec un large choix de noisettes à insérer ou pas, fortement paramétrable depuis l’espace privé.

Présentation

A l’instar de sa petite soeur plugin Escal-V2 dont elle reprend toutes les caractéristiques, cette version fonctionne de façon complète uniquement avec la version 3 de SPIP.


EscalV4 :

Avec l’évolution du plugin Agenda, la page d’Escal affichant l’agenda en pleine page ne fonctionne plus sur SPIP3.2, c’est donc l’occasion de proposer une version 4 d’Escal corrigeant le problème car on ne peut pas faire cohabiter les 2, en tout cas je ne sais pas faire ;-) .

Si vous êtes en SPIP 3.2 avec la version 3 d’Escal et que vous vouliez passer à la version 4, vous devez :

  • désactiver Escal (surtout pas le désinstaller car vous perdriez votre configuration d’Escal)
  • le réinstaller via la page "Ajouter des plugins"

Escal devient en grande partie paramétrable directement depuis l’espace privé :
-  choix du layout (position des colonnes)
-  choix de la présence (ou absence) des blocs latéraux et centraux, choix de leur colonne et choix de leur ordre
-  choix de l’image de fond et de l’image du bandeau
-  choix des couleurs de fond, du texte et des bords (encore plus facile avec le plugin Palette (version 1.4.x pour SPIP 3.0.x)
-  choix du menu
-  choix de la zone d’identification
-  présence ou absence de certains éléments (ombres latérales, titre du site dans le bandeau ...)
-  choix des arrondis
etc

Escal est valide XHTML Strict 1.0 (hormis les erreurs provoquées par l’utilisation d’ajax pour la noisette de recherche multi-critères et celles dues au plugin Mini-Calendrier)

Escal s’internationalise de plus en plus avec les langues suivantes : allemand, anglais, espagnol, espéranto, italien, japonais(en test), letton et néerlandais.

De plus, Escal installe maintenant (version 3.72 et suivantes) pour vous le groupe de mots-clés "affichage" avec tous les mots-clés utilisables dans Escal.

Ainsi, en quelques clics, on peut personnaliser son site.

Bien sur, on peut toujours mettre le nez dans le moteur pour aller plus loin dans la personnalisation, comme avec Escal-V2. Toutes les règles CSS que vous mettrez dans /squelettes/styles/perso.css continueront à prendre le pas sur les règles CSS d’Escal.

Maintenant, EscalV3 nécessite les plugins "Agenda" et "Calendrier-mini". Ceux-ci sont donc automatiquement téléchargés et activés lors de l’activation d’Escal.

Documentation et démonstration

Vous pourrez trouver des explications nombreuses et détaillées sur le site de démonstration où vous pourrez aussi utiliser le forum du site pour faire part de vos questions, suggestions, remarques, ... Ce site n’est un modèle d’esthétique et d’ergonomie car il veut montrer un maximum de possibilités d’Escal.

En discuter

Pour discuter d’Escal, proposer des améliorations ou évolutions, résoudre un problème, 4 solutions :

  • écrire un message dans le forum de cet article
  • écrire un message sur le site de démonstration (sous un article ou dans le forum du site)
  • écrire un message à la liste de discussion « spip-avec-escal@rezo.net » : vous abonner et participer

Si vous avez des idées de paramétrage à rajouter, n’hésitez pas à m’en faire part. Je les mettrais en place ... ou pas !

Discussion

58 discussions

  • Bonjour,

    j’ai donc modifié l’article en supprimant la partie concernant spipfactory.fr

    comme demandé via IRC

    Répondre à ce message

  • 4

    Bonjour,

    Je suis au jour le jour les évolutions d’Escal V4.

    Après chaque mise à jour, je dois vider le cache sinon le site en ligne est chamboulé.

    Ce n’est pas primordial mais y aurait-il une possibilité d’y remédier ?

    • Bonjour,

      la question est délicate
      « Je suis au jour le jour les évolutions d’Escal V4. »
      Comment ?

      « Après chaque mise à jour, je dois vider le cache sinon le site en ligne est chamboulé. »
      Possible d’avoir une url pour comprendre ce que chamboulé exprime

      « Ce n’est pas primordial mais y aurait-il une possibilité d’y remédier ? »

      je pense mais il y a différente façon, par un cron a la main, via spip tu est chez quel hébergeur ?

    • Jaseur Boreal

      Bonjour,

      C’est normal qu’après une mise à jour, certains caches, gardent en mémoire d’anciens réglages.

      Lorsqu’on effectue des modifications directement sur les fichiers, particulièrement en mettant à
      jour une feuille de style ou un script Javascript calculés par des squelettes SPIP si les options de compressions sont actives il faut alors vider manuellement :
      -  le cache de spip - coté privé
      -  le cache de son navigateur qui a son propre cache, que ce soit pour les pages ou pour les éléments AJAX. Il faut aussi penser à le vider « ctrl + F5 »
      @+

    • Bonjour,

      @spipfactory.fr
      Je suis les évolutions des plugins dans l’espace privé.
      Mon hébergeur est lolipop.jp
      Qu‘est-ce que je dois lui poser comme question ?

      @ Jaseur Boreal

      Je vide bien à chaque fois le cache de Spip. C’est ce que je voudrais éviter à chaque mise à jour d’Escal même si ce n’est pas bloquant.

    • Certaines mise à jour d’Escal nécessitent en effet un vidage de cache mais pas toutes, loin de là !

    Répondre à ce message

  • 2

    Bonjour,
    Merci infiniment pour ce plugin qui est très joli et très très intéressant.
    J’aimerai bien savoir monsieur Christophe est ce il y en a possibilité d ’avoir un fichier css des paramètres enregistrés dans son espace privé pour pouvoir le réinstaller (sur une autre machine) sans avoir à refaire ses paramètres à nouveau

    Merci

    • Bonjour

      S’il te plaît, laisse-moi mon « Jean » ;-)

      Sinon, il faut placer toutes tes surcharges CSS dans un fichier perso.css qui doit se trouver dans /squelettes/styles et ce fichier est bien sur transférable.

      Sinon, les réglages faits dans la configuration d’Escal sont stockés dans la base de données donc en transférant cette base, tu transféreras aussi tes réglages.

    • Et pour compléter, s’il s’agit de copier ses réglages d’escal sur un site différent et non sur une copie du site, il y a le plugin import export de configuration.

    Répondre à ce message

  • 1
    liberte

    Bonjour,

    J’ai fait le grand saut Escal V3 a Escal V4 (ca prend quelques seondes). Escal V4 semble avoir garde les reglages que j’avais faits pour la version V3. Maintenant Escal V3 est dans les plugins inactifs. Je peux le desinstaller ?

    Répondre à ce message

  • 3
    jac36949

    Bonjour,

    Je reprends cette discussion au bon endroit, merci Maïeul.

    Petit rappel :
    1. Je souhaite pouvoir afficher l’info crédit d’une photo publiée avec Galleria.
    2. Jean-Christophe m’informe qu’il a réalisé une mise à jour sur Escal qui répond à la demande.
    3. Dans mon espace privé, Escal est dans les plugins verrouillés, je ne peux pas faire de mise à jour.
    4. Je suis hébergé chez SpipFactory

    • Il faut demander à spipfactory de mettre à jour le plugin, je suis sur qu’il le ferait avec plaisir.

    • spipfactory

      Bonjour,

      3. Dans mon espace privé, Escal est dans les plugins verrouillés, je ne peux pas faire de mise à jour.
      4. Je suis hébergé chez SpipFactory

      Alors effectivement Escal est dans les plugins verrouillés puisque l’hébergement est en mutualisation et de plus seul le squelette escal est proposé est donc l’activation est forcé de cette manière ;)

      Bien entendu je vais me faire un plaisir de mettre a jour, toutefois les plugins sont mis a jour le 10,20,30 du mois automatiquement par un script maison.

      pour info il existe une liste pour les hébergés spipfactory et également une liste pour les utilisateur d’Escal ...

    • jac36949

      Bonjour

      Super, ça marche...
      Merci pour tout...

    Répondre à ce message

  • 47

    Bonjour

    Lors de l’activation du plugin Escal je perds l’accès à la gestion des plugins.
    Le site est visible sous escal, l’espace privé fonctionne, sauf la page "Gestion des plugins" : page vide avec le message "MAJ init."

    J’ai tenté plusieurs manips :
    désactiver Sarka-SPIP, désactiver plusieurs plugins, désactiver tous les plugins, vider le cache, désactiver temporairement le cache...sans succès !
    Si je supprime le dossier "escal », je retrouve la page de Gestion des plugins.

    J’ai créé un site neuf ( installation de spip 3.1, création de deux rubriques, 3 articles,….), puis j’ai téléchargé Escal et j’ai toujours le même problème…

    Je travaille sur un iMac sous macOS Sierra 10.12.6.

    Mon site est en local avec MAMP 4.2., PHP 7.1.8, SPIP 3.1.7.

    J’ai vérifié les droits en écriture sur les dossiers…
    Jai changé de navigateur…

    Suis-je seul dans cette situation ? Quelqu’un peut-il m’éclairer ??

    • testé rapidement avec escale v4 > pas de problème. Je pense que d’activer les optioons de debage PHP pourrait nous donner une piste. Dans ton mes_options.php (à créer dans config si besoin)

      <?php
      define('_NO_CACHE', -1);
      define('_INTERDIRE_COMPACTE_HEAD_ECRIRE', true);
      error_reporting(E_ALL^E_NOTICE);
      ini_set ("display_errors", "On");
      define('SPIP_ERREUR_REPORT',E_ALL);
      $GLOBALS['taille_des_logs'] = 500;
      define('_MAX_LOG', 500000);
      define('_LOG_FILELINE',true);
      define('_LOG_FILTRE_GRAVITE',8);
      define('_DEBUG_SLOW_QUERIES', true);
      define('_BOUCLE_PROFILER', 5000);

      à n’utiliser que sur le site de dev local.

    • Je ne suis pas programmeur..
      j’ai copié les instructions dans un éditeur de texte puis j’ai renommé le fichier en « mes_options.php » que j’ai placé dans Config : le site est alors devenu inaccessible ( HTTP ERROR 500).

    • C’est vraiment très, très étrange. Parce que vous avez fait exactement ce qu’il fallait faire, et vous ne devriez pas avoir d’erreur 500.

      J’avoue ne pas trop savoir, étant donné que je n’arrive pas à reproduire le bug, et que les outils qui permettrait de debuger bugent chez vous....

    • Bonjour

      Étrange en effet. Et si tu enlèves ce code, de ton fichier, l’erreur 500 disparaît-elle ?

      Autre question, quand tu parles d’éditeur de texte, il ne s’agit pas d’un traitement de texte comme LO-Writer ou Word mais bien d’un éditeur comme notepad++ ?

    • Yo

      est t’il possible d’avoir une copie de mes_options.php ?

      ceci étant dit tu a bien l’ouverture et la fermeture du code soit

      <?php
      bla bla bla
      ?>

    • @amilcar : la fermeture n’est pas obligatoire, et même déconseillé dans certains cas.

    • Cool j’ai appris un truc

      merci Maieul

    • Bonjour
      Merci pour vos messages, j’essaie de répondre à tous :

      Le fichier mes_options.php n’existait pas, je l’ai créé avec l’éditeur textedit.app.
      Je l’ai copié dans Config ce qui a bloqué le site, puis je l’ai supprimé et le site a fonctionné.
      Je joins une image du fichier

      Je n’ai pas de fichier mes_fonctions.php
      J’ai aussi vidé le dossier tmp
      J’ai un dossier squellettes

      Je travaille sous macOS Sierra 10.12.6, le logiciel qui me permet d’utiliser un site en local est MAMP (version gratuite, il existe une version payante...).

      Dernière action : J’ai créé un nouveau site en local, en installant SPIP 3.1.7 ; il n’y avait que les plugins installés avec SPIP ( vérouillés ) ; j’ai créé un dossier plugins puis un dossier auto et j’ai téléchargé et activé Escal : même problème...

      Je n’ai pas essayé de tester ailleurs, c’est peut-être ce qu’il faut faire.

    • Bonjour

      Ça ressemble à un problème sur ta machine.
      Et si tu essaie d’installer un autre plugin qu’Escal ?

    • Hello jac36949

      si tu souhaite tester ailleurs je t’ouvre un espace.

      aprés je n’ai que ce lien : https://contrib.spip.net/-SPIP-sur-Mac-OSX-

    • Bonjpour

      J’ai installé un autre plugin sans rencontrer ce problème.
      Je vais essayer de tester ailleurs.

    • Là j’avoue que je ne comprends pas. Une incompatibilité d’Escal avec Mac ?

      Et si tu installe les plugins « agenda » et « mini-calendrier » sans escal, ça donne quoi ? Histoire d bien cibler l’origine vers Escal.

    • Je ne pense pas que l’incompatibilité soit lié au système d’exploitation, mais peut être à la version de PHP / aux extensions qui vont avec de Mamp.

      Par contre je sais ce qui ne va pas dans mes_options.php. Tu a utilise textdit.app qui a enregistré ton fichier en RTF (mais avec une extension .php). Et du coup cela fait planter ton site ;-) Tu dois enregistre ton fichier en format text brut (c’est une option dans textedit.app).

      Mais je pense que d’une manière plus globale, pour « éditer du code » ((et tu pourras être amené à le faire) il vaut mieux que tu utilise un logiciel spécialisé, qui t’enregistrera le code en text brut et t’aidera à voir le code clairement. Je peux te conseiller par exemple https://atom.io/, mais il y a d’autres.

    • Bonjour

      J’ai installé les plugins « agenda » et « mini-calendrier » et ils fonctionnent.

      J’ai transformé le fichier « mes_options.php » en texte brut et le résultat me déconcerte...
      je joins une image de la fenêtre.

      J’accepte la proposition de spipfactory pour tester ailleurs

    • @Jack : c’est bien, cela veut dire que le mode debug fonctionne. Maintenant il ne reste plus qu’à l’appliquer sur la page qui fonctionne pas, celle de chargement des plugins lors de l’activation d’Escal, si j’ai bien compris.

    • Pour Maïeul

      voilà deux images du résultat

    • Pour Maïeul

      A priori je ne peux pas attacher 2 fichiers à un commentaire, voici l’autre capture.

    • tu as activé escal là ?

    • et non, j’ai simplement déposé le fichier mes_options.php dans le dossier config et là, je n’ai plus accès à l’espace privé.

    • je comprend plus rien. Tu m’a présenté il y a peu une copie d’écran de l’espace privé....

    • Le Jaseur Boréal

      Bonjour,

      En survolant cette discussion propre à ESCAL, y a un truc que j’ai pas bien capté, car dans le premier message du 17 janvier @jac36949 y mentionne le squelette Sarka-Spip !

      A tous z’hasards et sans sarkasmes, p’tet que des broutilles d’anciens réglages de Sarka-spip mettent le zouk dans Escal ?

      Spip-Factory, l’association d’escaliens coopérants, m’a offert une idée il y a peu de temps, d’aller vider le cache dans /local/cache-css ....

      Certains réglages se complaisent à jouer à cache-cache, et à nous taquiner , et comme el Karnaval ed’Duinkerke ch’est tantôt , p’tet qu’issent kachent ?

      @+

    • Effectivement je ne retrouvais plus l’accès à l’espace privé (retour en boucle sur la saisie du mot de passe) ;

      J’ai pu retrouver la page, accéder à la gestion des plugins et installer Escal.

      Résultat sur l’image « erreur1 ».

      Après avoir activé le lien « Si votre navigateur...... » j’obtiens l’écran « erreur2 ».

    • merci, on y voit plus clair. Tu avais déjà une version d’Escal installé avant (même il y a longtemps et désactivé entre temps) ?

    • le plus simple serait encore que tu m’envoi un dump phpmyadmin de ta base (mon prenom sans le trema @ mon prenom sans le trema.net).

      Je regarderai en fin de semaine.

    • Bonjour

      Je travaille sur des copies que je fais avant d’installer Escal.

      Je t’ai envoyé une sauvegarde de la base

    • Hello

      Je viens de tomber sur un site hébergé dans notre académie avec le même problème : page des plugins vide.

      Ce que j’ai fait : par ftp j’ai supprimé le dossier /escal du dossier /plugins/auto puis j’ai réinstallé Escal via l’espace privé de spip et le souci a disparu.

    • Je reproduis le problème. Je regarde et te dis.

    • @jean-christophe : tes fonctions d’install / de désinstallation était mal écrite, du coup cela plantait lors de l’install / la déinstall.

      Corrigé en https://zone.spip.org/trac/spip-zone/changeset/108641,
      https://zone.spip.org/trac/spip-zone/changeset/108642
      https://zone.spip.org/trac/spip-zone/changeset/108643
      et
      https://zone.spip.org/trac/spip-zone/changeset/108644

      @jac36949 la version 3.87.75 devrait être installable.

      Malheureusement la génération de zip des nouvelles versions est au point mort sur la zone (je crois que b_b s’occupe ede relancer), ce qui veut dire que l’installateur auto ne marche pas. Mais je t’envoie par mail le zip de la version.

    • Cool

      J’avais recopié le code fourni par Arnaud à l’époque car ça dépassait mes compétences (et c’est toujours le cas).

      Un très grand merci pour la correction du bug et pour le temps passé.

    • les zips sont repartis.

    • Super, Escal fonctionne sur mon site en local....

      Grand merci à tous

    • Bonjour
      Mes albums ont disparu...

      En local jai récupéré mes albums de photos.
      Spip 3.1.7
      Escal 3.87.75
      Galleria 1.3.5
      Albums 3.5.5

      Sur le site distant nouvellement installé chez SpipFacory je n’ai plus les albums
      Spip 3.2.0
      Escal 4.0.22
      Galleria 2.0.0
      Albums 3.5.5

      Y a-t-il une alternative pour constituer des gropes de photos ?

    • C’est bizarre cela. Comment a tu procédé au transfert ? Via l’outil de sauvegarde de SPIP ? Avais tu deja activé le plugin album lorsque tu a restaurer la sauvegarde ?

      Dans tous les cas, une solution pour rétablir cela serait
      1) De faire via PHPmyadmin (normalement installé avec MAMP) des tables spip_albums et spip_albums_liens
      2) avec le phpmyadmin de ton hébergeur, réimporter ces tables.

      ps : cela n’a rien à voir avec Escal, il aurait mieux value poser la questions sur les listes de SPIP et ou sur le forum de SPIP.-

    • Jaseur Boréal

      Bonjour,

      Une question technique, comment la sauvegarde de la base et des tables a-t-elle été faite ?

      • Est-ce que c’est une sauvegarde par spip ? Sqlite ou MySQL ?
      • Est ce que c’est une sauvegarde MySql directement chez l’hébergeur ?

      Il m’est arrivé sur d’anciennes versions 3.0xx, 3.1xx de spip, c’est très rare avec la version 3.2 de spip, que sur l’ensemble des tables sauvegardées par Spip, certaines soient sauvegardées affreusement vides. Et quand on restaure ces tables , on attrape quelques cheveux blancs supplémentaires ;-)) A l’époque, j’ai béni St Octave, d’avoir prévu les multiples sauvegardes automatiques chez OVH !

      Cela pourrait expliquer la disparition de certains liens inscrits dans des tables avec les images existantes et rangées dans le sous-dossier /IMG du site.

    • Le transfert a été fait par SpipFactory à mon grand soulagement !!!
      il y avait des problèmes sur ma base qui ont été résolus.
      Ma base était en Sqlite et elle a été convertie en MySQL, c’est peut-être l’origine du pb.
      En l’état je retrouve mes articles, mes documents, photos...
      Je n’ai que quelques albums a reconstituer, ce sera facile...

    • spipfactory

      des problèmes sur ma base qui ont été résolus

      sans doute pas a 100% la preuve en est que tu a perdu les albums
      ceci dit entre le spam et hack de la bdd

      j’ai peu être viré un truc de trop.

      mais comme tu n’a que quelques albums a reconstituer alors ça roule ;)

    • jac36949

      Bonjour

      J’utilise le plugin Galleria pour publier des galeries photos.
      j’obtiens pour chaque photo les infos « Titre » et « Descriptif ».

      J’aimerais également publier l’info « Crédit » mais je n’ai pas trouvé l’option qui convient.

    • Hello

      Il aurait été préférable de commencer une nouvelle discussion ...

      Sinon, il n’y a pas d’option pour cela mais je viens de modifier mon modèle pour qu’il affiche les crédits s’ils existent. Livré il y a quelques minutes.

    • jac36949

      Bonjour

      effectivement le sujet méritait une nouvelle discussion, je suis encore novice sur l’usage du forum, j’apprends en découvrant...

      Merci pour la réponse très rapide, si je comprends bien je dois mettre les mains dans le moteur, je veux dire le HTML.....
      Je relève le défi et je reviens sur le forum si besoin.

      Cordialement

    • Non, pas besoin de te salir les mains. Tu mets juste Escal à jour et hop !

    • jac36949

      Bonjour

      Je n’ai pas l’icône de mise à jour sur Galleria dans l’interface de Gestion des plugins.

      J’hésite sur la méthode :
      -  Télécharger à nouveau le plugin pour écraser l’ancien ?
      -  Supprimer le plugin installé avant de télécharger le nouveau ?

      Merci de me guider....

    • 1. Je ne vois pas le rapport directe avec ce plugin.
      2. Dans tous les cas peux tu rouvrir un fil plutot que de poursuivre le précédent fil ?

      Je ne vais pas te répondre sur le fond maintenant, car c’est la deuxième fois qu’on te signale ce problème.

    • Si si il y a un rapport car Escal utilise un modèle galleria légèrement personnalisé.

      Et c’est donc de la mise à jour d’Escal dont je parlais. c’est d’ailleurs ce que j’ai écrit dans mon post précédent...

    • Bonjour

      Désolé de revenir sur ce fil. Lorsque je me connecte sur spip-contrib j’arrive directement sur cette page et je n’ai pas trouvé comment ouvrir une nouvelle discussion...

      J’ai bien compris que la mise à jour concerne Escal ( et non Galleria comme j’avais d’abord pensé à tort ).
      Dans l’espace privé Escal est un plugin vérrouillé et l’icône de mise à jour est inactive.

      Me voilà donc avec deux questions :
      Comment reprendre une nouvelle discussion ?
      Comment mettre à jour Escal ?

    • tout en bas de la page tu as « répondre à cet article » pour ouvrir une nouvelle discussion, et pas « répondre à ce message ».

      (je suis d’accord, il faut tout scroller ... mais si on met tout en haut, les gens ouvrent une discussion à chaque fois à la place de répondre).

      Si ton plugin est dans la liste verrouillé, cela veut dire qu’il a été installé dans plugins-dist (ce qui est bizarre, mais peut arriver). Il faut donc que tu envoie la nouvelle version via ftp dans plugins-dist. Puis tu repasse sur la page de gestion des plugins pour s’assurer que les mises à jour de bdd se font bien.

    • Hello jac36949

      Etonnant cette histoire de plugin Escal verrouillé.
      Tu es hébergé chez qui ?

    Répondre à ce message

  • 4
    nourieff

    Bonsoir,

    Voilà deux bonnes heures que je tente de télécharger le Plugin d’Escal V4, en suivant bien tous les conseils. Mais...

    Desactiver Escal V3 ou non n’y change rien, le Plugin V4 n’est pas proposé.

    Du coup je suis directement allé chercher le lien du plugin sur plugin.spip mais, il faut avoir spip 3.2

    Donc je me suis dit, allez mettons Spip à jour (avec le spip loader), ce que j’ai fait mais pour passer au 3.2 il faut la version je sais plus combien de php apparemment et la je n’ai plus la main, c’est l’hébergeur et j’ai la version de php 5.3.3 donc c’est mort. (Du coup je suis passé à Spip 3.1.7 mais je pense que ça n’a même pas marché !)

    Du re-coup pas de mise à jour Spip, pas de mise à jour Escal (et donc accessoirement pas de rubriques par colonnes avec tout le boulot que tu as fait)...

    J’ai raté une étape ?

    Merci

    • Bonsoir
      je viens de faire la manip. Cela c’est visiblement très bien passé. J’étais déjà en 3.2

    • Bonsoir ,

      Après lecture ....

      Desactiver Escal V3 , le Plugin V4 n’est pas proposé.

      Normalement c’est la bonne méthode, contacte moi pour un acces webmestre que je jette un oeil

      le lien du plugin sur plugin.spip mais, il faut avoir spip 3.2

      ben oui c’est pas assez explicite

      “si vous êtes en SPIP 3.2 avec la version 3 d’Escal et que vous vouliez passer à la version 4, vous devez :

      désactiver Escal (surtout pas le désinstaller car vous perdriez votre configuration d’Escal)
      le réinstaller via la page "Ajouter des plugins"”

      Donc je me suis dit, allez mettons Spip à jour (avec le spip loader), ce que j’ai fait mais pour passer au 3.2 il faut la version je sais plus combien de php apparemment et la je n’ai plus la main, c’est l’hébergeur

      donc pour rappel
      « SPIP 3.2

      Serveur Apache ou compatible (versions supérieures à la 1.2x)
      PHP 5.4.0 minimum, PHP 7.x
      MySQL 5, SQLite3
      NetPBM, Imagick/convert, GD1, GD2 (requis) (plus Freetype pour les filtres |image_typo).
      Bibliothèques PHP : php-xml, php-gd
      jQuery 3.2 intégrée
      jQuery UI 1.12 intégrée »

      et j’ai la version de php 5.3.3 donc c’est mort. (Du coup je suis passé à Spip 3.1.7 mais je pense que ça n’a même pas marché !)

      effectivement c’est la bonne version spip par rapport a ton php

      Du re-coup pas de mise à jour Spip, pas de mise à jour Escal (et donc accessoirement pas de rubriques par colonnes avec tout le boulot que tu as fait)...

      J’ai raté une étape ?

      non ...........

      Quel est donc cette Hébergeur ?

      Mais il y a peu être une solution ;)

      Rejoindre une Équipe motivée qui a créer un hébergement mutualisé pour faire tourner Escal et permettre de partager les coûts.

      https://spipfactory.com

    • Le Jaseur Boréal

      Faut-il faire confiance à un hébergeur qui ne met pas à jour le PHP pour ses clients ?

    • Bon tout a été dit : la version 4 d’Escal n’est installable que sur SPIP 3.2

    Répondre à ce message

  • 4

    Bonjour Jean Christophe,
    « L’option » favicon.ico perso. a disparue avec les denières révisions.

    • Problème résolu en mettant favico.ico dans « squelettes » à la place de « racine ». Pourtant en octobre, placé à la racine du site, le favicon perso s’affichait... (?)
      Désolé du dérangement.

    • Vers 19h, j’ai indiqué en détail avoir résolu le problème...
      mais mon message a disparu (?).
      Qu’adviendra-t-il de celui-là... en tout cas j’aurais essayé.

    • Hello

      Je vois bien 3 messages ... il y en a eu d’autres ?

      Le fichier favicon doit en effet être placé dans /squelettes
      Le plus bizarre est que ça fonctionnait en le plaçant à la racine du spip !

    • Il me semble que certaines config apache envoie automatiquement le favicon.ico situé à la racine. Mais SPIP redirige via le .htaccess sur le favicon du squelette > si vous avez activé le .htacess ou avaez eu un changement de config apache niveau serveur, cela peut expliquer ceci.

    Répondre à ce message

  • 3
    philyray

    Salut,

    J’ai constaté que les blocs latéraux gauches et droits disparaissent dans les rubriques contenant des sites référencés. Les blocs latéraux droits apparaissent tout en bas à gauche.

    J’ai rajouté le bloc calendrier pour voir si ça changeait quelque chose et modifié le nombre d’article et de sites qui peuvent apparaitre par pagination. ça n’a rien changé au problème.

    voici mes deux rubriques qui sont décalées : http://spip.technoloy.fr/spip.php?rubrique7&lang=fr et http://spip.technoloy.fr/spip.php?rubrique6&lang=fr

    Est-ce que les sites référencés doivent toujours être liés à une rubrique et est-ce que je peux les supprimer sans risquer de ne plus pouvoir les utiliser comme sites favoris ?

    Cordialement.

    PS : J’ai réactivé la moitié du couteau suisse et les ralentissements ne sont pas revenus. Vu que j’avais supprimé tout le dossier pour le remplacer, je ne peux plus trouver quelle lame est fautive. désolé.

    Répondre à ce message

  • 8
    philyray

    Salut,
    Après ma mise à jour majeur spip 3.0 à spip 3.1 par tranfert ftp grâce à Filezilla car en automatique avec spip_loader s’est arrêté en me disant accès refusé ou sécurisé, mon site a pu démarrer. Le seul gros problème est que chaque page prend 3min chrono pour s’afficher. Avant c’était immédiat.
    Sous l’espace rédacteur, ça va à une vitesse normale. C’est instantané.
    J’ai suivi les consignes de la page : https://contrib.spip.net/Mettre-a-jour-vers-SPIP-3-1-pour-les-nuls#FTP
    D’où pourrait venir ce ralentissement ?

    cordialement.

    • Quel est donc l’Hébergeur ?

      Une URL pour voir ?

      c’est quand même bizarre l’arrêt de spiploader

      vider le cache , pour voir si ça change quelquechose

    • philyray

      1&1 Unlimited Plus

      http://spip.technoloy.fr/

      Je vide le cache après chaque mise à jour de plugin. Je l’ai déjà vidé au moins 5 fois depuis hier et je lance le recalcul des pages.
      Mon autre site qui est aussi lent voir plus est agora-project mais ça a toujours été comme ça depuis que je l’ai installé.

    • Hello

      Difficile à dire comme ça. Quelques pistes :

      • Quels sont les plugins qui sont installés ?
      • Que se passe-t-il si tu renommes ton dossier /squelettes et squelettesOLD par exemple
      • Que se passe-t-il si tu désactives Escal ?
    • philyray

      Salut,

      ° Mes plugins installés sont dans l’image en pièce jointe dont les incompatibles qui sont : Accès restreint, biblio check, bibliographie ARES, Lecteur de Media de MediaSPIP, MediaBox, MediaElementplayer, Microblog, SPIP Geoportail, video accessible, kaye et ocr.

      ° En renommant le dossier /squelettes en squelettesOLD : le bandeau du site disparait.

      °Quand je désactive Escal, je tombe, dans l’espace public, sur une page simple avec l’icone du site et la présentation du site ainsi que les rubriques. Le passage entre les rubriques prend aussi 3 min.

      J’ai trouvé cette discussion sur le forum mais mes connaissances sont limitées pour faire toutes les vérifications : http://forum.spip.net/fr_244583.html#forum267745 .
      C’est la plus complete que j’ai trouvé sur un gros ralentissement de SPIP à la suite d’une mise à jour majeure.

    • Bon donc à priori, Escal n’est pas en cause car sa désactivation ne règle pas le problème.

      Tu peux peut-être essayer de désactiver tous tes plugins, de vider le cache par ftp et de voir si la lenteur persiste. Si c’est le cas, essayer de téléverser à nouveau le spip au cas où un fichier serait mal passé.

      As-tu contacté ton hébergeur ?

    • Salut,

      Effectivement, quand j’ai vu sur le forum que c’était arrivé à plusieurs personnes en 2013, j’ai compris que ce n’était pas Escal.

      ° J’ai vidé le cache par ftp en supprimant partiellement le contenu de /tmp/ et entièrement celui de /local/. ça n’a rien changé.

      ° j’ai désactivé tous les plugins puis réactivé escal qui en a réactivé 2 autres. Résultat : moins de 2 secondes entre chaque page ! ! ! ! ! ! ! ! Je vais réactiver l’un après l’autre chaque plugin pour voir lequel est le petit farceur puis j’irai pour la 2e soirée consécutive manger au fast food. Mais ça en valait le coup.

      °Quand j’active le plugin le couteau suisse 1.9.12, ça recommence à faire 3min par page. J’ai réinitialisé et désactivé tous ses outils : c’est vrai qu’il agit beaucoup sur l’ensemble des fonctionnalités de spip. La vitesse est à nouveau convenable. Je pense que je vais le désinstaller pour le réinstaller.

      Encore merci pour les conseils.

    • °Quand j’active le plugin le couteau suisse 1.9.12, ça recommence à faire 3min par page.

      hi hi hi ta vu Jc encore lui ..............

      Bon dit moi donc quel lame utilise tu ? ; je suis presque sur que des plugins independant les remplace et du coup tu pourra viré le CS

    • Il serait plus malin de repérer quelle est la lame du couteau suisse qui pose souci en les désactivant une à une avec vidage de cache à chaque fois. Ce qui permettrait peut-être à Pat, l’auteur du plugin, de corriger le bug.

      J’utilise un certain nombre de lames sans souci.

    Répondre à ce message

Ajouter un commentaire

Qui êtes-vous ?

Pour afficher votre trombine avec votre message, enregistrez-la d’abord sur gravatar.com (gratuit et indolore) et n’oubliez pas d’indiquer votre adresse e-mail ici.

Ajoutez votre commentaire ici

Ce champ accepte les raccourcis SPIP {{gras}} {italique} -*liste [texte->url] <quote> <code> et le code HTML <q> <del> <ins>. Pour créer des paragraphes, laissez simplement des lignes vides.

Ajouter un document

Suivre les commentaires : RSS 2.0 | Atom

Dernière modification de cette page le 12 décembre 2018