Actualización de seguridad SPIP 2.1.9

Hola!

Nuestros servicios (gracias de nuevo Arnault) ha descubierto un agujero de seguridad en SPIP, lo que permite una inyección cross-site-scripting (XSS).

El error se remonta a más de cinco años (se presentó 08 de octubre 2005), y por ello está claro que TODAS las versiones de SPIP se ven afectadas.

Para proteger su sitio, sólo tiene que actualizar el archivo 404.html, ubicado en el directorio :

  • dist/ en la versión SPIP 1.9
  • squelettes-dist/ en versiones SPIP 2.0 o 2.1
  • extensions/dist_2007/ en la versión en desarrollo

Si ha personalizado la plantilla, la solución es simplemente quitar el asterisco y los filtros para transformar la expresión #ENV*{erreur}|propre en #ENV{erreur}.

Les recordamos a todos que la mejor manera de informarnos de las fallas o defectos sospecha es enviar un correo electrónico a spip-team@rezo.net.

Siéntete libre de utilizar los diferentes medios disponibles para obtener ayuda con esta migración:

Cómo actualizar?

Como de costumbre, hay varios métodos de la actualización:

1. Pantalla de seguridad si ahora no tienes tiempo de hacer una actualización completa, puedes asegurar tu sitio en dos minutos descargando la versión 1.0.1 de la pantalla de seguridad, descomprimiendola en config/ ver. http://www.spip.net/es_article4243.html

2. Mediante spip_loader.php : si has instalado spip_loader, ve a la dirección http://DIRECCION_DE_TU_SITIO/spip_loader.php para actualizar a la versión SPIP 2.1.9

3. Mediante FTP : SPIP 2.1.9 está disponible en http://files.spip.org/spip/stable/

4. O bien por SVN ; realizando simplemente svn up

  • en la rama 2.1 : svn ://trac.rezo.net/spip/branches/spip-2.1
  • en la rama estable : svn ://trac.rezo.net/spip/branches/spip-2-stable/
  • mediante el tag : svn ://trac.rezo.net/spip/tags/spip-2.1.9/

Discussion

No discussion

Add a comment

Avant de faire part d’un problème sur un plugin X, merci de lire ce qui suit :

  • Désactiver tous les plugins que vous ne voulez pas tester afin de vous assurer que le bug vient bien du plugin X. Cela vous évitera d’écrire sur le forum d’une contribution qui n’est finalement pas en cause.
  • Cherchez et notez les numéros de version de tout ce qui est en place au moment du test :
    • version de SPIP, en bas de la partie privée
    • version du plugin testé et des éventuels plugins nécessités
    • version de PHP (exec=info en partie privée)
    • version de MySQL / SQLite / PostgreSQL
  • Si votre problème concerne la partie publique de votre site, donnez une URL où le bug est visible, pour que les gens puissent voir par eux-mêmes.
  • En cas de page blanche, merci d’activer l’affichage des erreurs, et d’indiquer ensuite l’erreur qui apparait.

Merci d’avance pour les personnes qui vous aideront !

Par ailleurs, n’oubliez pas que les contributeurs et contributrices ont une vie en dehors de SPIP.

Who are you?
[Log in]

To show your avatar with your message, register it first on gravatar.com (free et painless) and don’t forget to indicate your Email addresse here.

Enter your comment here

This form accepts SPIP shortcuts {{bold}} {italic} -*list [text->url] <quote> <code> and HTML code <q> <del> <ins>. To create paragraphs, just leave empty lines.

Add a document

Follow the comments: RSS 2.0 | Atom